SC2 'Freezing' in iRacing, mid race. Turn off and iRacing 'unfreezes'

Hi guys,

I’m sure this issue or similar has been solved , so apologies in advance if it’s obvious. I can’t seem to find an answer. It is very frustrating and basically ruining every race at the moment.
Mid race in iRacing, when cornering (rarely happens on straights as far as I can work out), iRacing will ‘freeze’, either for a couple of frames and then return to normal, or completely freeze with a static screen and looping sound.
If it returns to normal after a split second, the wheel is completely dead, i.e. could spin freely, for the time that the freeze occurs, and then regains torque etc. when the screen un-freezes, but most of the time you of course crash.
If it freezes on a static screen with the looping sound, the sim will completely un-freeze and return to normal upon turning off the power button of the SC2. By this point you have of course crashed as well. You can then activate the profile in true drive again and get going, but it might last 10 minutes until one of the two scenarios above happens again.

It tends to happen more frequently on high output cars like LMP2, if that helps. I’m running truedrive firmware 1.0.15, the SC is an Ultimate, and PC is fully up to date etc…

Any obvious thoughts?!

Update - I found a similar previous thread with some good points from @Gifted. I have since found out my firmware wasn’t fully updated, and I have changed USB ports, with the SC2 usb wire now not touching the actual rig itself at all.

I haven’t tested yet but going to give it a go shortly, hopefully with positive progress.

1 Like

Update - it’s worse. Twice over one lap of qualifying (don’t know why it doesn’t happen in practice as it seemed to be ok for 3 laps), as I was turning left for normal corners (not overly forceful nm wise), the ‘usb device connected’ chime would sound in my headphones audibly as if you had just turned the SC2 power button on, and then the wheel would auto rotate all the way to the left and be stuck there, until turning it off at the base and re-starting.

Lost about 150 iRating finding these things out :sweat_smile:

The only USB devices I have plugged in are pedals, SC2, steering wheel, and my screen.

This turning left until the stops thing had not happened before I updated the firmware just now.

Anyone have any ideas as it’s un-usable at the moment :frowning:


The firmware version 2020.10 is the most stable at the moment. There is a note about some USB issues on the firmware download page.

Thanks Mika, I will try going back to that one. Do you have any idea what would have caused the issues prior to the ‘steering all the way to the bumpstops on the left’ issue?

I have also ordered an isolator as suggested in a previous thread.

The previous form of the issue (screen frozen until SC powered off) did not cause any kind of audible USB chime btw. I was actually on the 2020.1 firmware when this was occurring. The freezing probably never happened for the first 5 months, but has been more frequent recently. No other changes to rig.

Looking forward to getting to the bottom of this…

@Mika. I updated the firmware to the settings below, but by the 5th corner (again a left hander but I had turned left before that), the USB chime sounded, and the wheel turned all the way to the bumpstops on the left, and does not release the force until manually powering down. Unless any further ideas I will open a ticket because this is not right?


Did you follow the firmware downgrade instructions?

Simucube 2 firmware downgrade

Thanks @Mika I hadn’t, I have done that now, is this downgraded enough or do the version numbers have to match?

In addition I pressed ‘start everything from scratch’, and I also physically separated out the USB lead so it’s not in contact with any other cable or any part of the rig. It’s still plugged into the same USB port. The cable has not moved in the last year otherwise.

I managed 5 laps of Le Mans just then successfully, which is great and a real step in the right direction! However, these changes or potentially reset to settings have done something unusual to the feeling of the car and the feedback. This is specifically in LMP2 at Le Mans which I have been using for the last week, so am quite familiar with what it felt like before. My TD settings are the same as they were before, as below.

Generally speaking, whereas previously you could really feel the weight of the car mid corner, now there is almost a dead zone (it’s not actually dead because there is some feedback) in the middle of the corner. I’m also feeling much less feedback from the rear of the car through the wheel which is causing more sliding due to lack of feel. Generally the feedback on straights is very detailed, you can feel small bumps. Then on turn in there’s decent weight to the wheel although probably not as much as before, and mid corner there’s a loss of detail. It’s as if the forces being fed through the wheel aren’t completely ‘smooth’, causing that slight jarring motion sometimes, where the feedback comes and goes?

It’s very noticable around the banked left hander of Indianapolis at Le Mans, which usually is very weighty due to the camber. The wheel feels almost light in the middle, in some parts of the corner, which did not happen previously. The following right hander of Arnage has the same ‘non-smooth’ feedback, where you expect it to feel heavy all the way through.

My settings in iRacing have remained the same. I’m also probably getting slightly less FB impact from kerbs, although that’s not so bad.

Do you have any idea what could be causing this, and potential fixes? Would my reset of settings have caused something to be changed outside of the profile settings below? I’ve tried to describe as best I can so apologies for the lengthy post.

It is downgraded enough now.

Restart from scratch does also reset the settings in the hardware settings tab, but that does not explain the feelings you have. Try with different cars and tracks and setups to rule those out.

Is it possible that the different TD versions and firmware interact slightly differently with the ‘max force’ slider on iRacing?

I wondered whether it could have been due to loss of detail so I pressed auto on the max force slider. This took the figure from 56nm where I had it, down to about 34nm on auto. I had to then reduce the nm down to 9 from 11 as I want to race for more than 20 minutes at a time…

However this did bring back a lot of the detail. Will test further but could be on the right track :slight_smile: :grinning:

Same issue here, with running on Trueforce 2020.10 (Simucube firmware version is on 1.0.33 though)