SC 2 Pro - Losing FFB mid corner for 1-2 sec

Looking forward to your feedback, as this one has all of us a bit stumped.

Well…that didn’t take long…just ran a test with 992 GT3R at Road America in a Test Drive on iRacing – and I did experience one loss of FFB in Turn 1 – same as before. I can still report that the FFB cuts/clips are much less frequent – that was only 1 clip in the test – but still mid-corner and surprising/jarrring.

I was testing with the new USB cord and ‘cleaned up’ device manager USB settings…

So I think we can rule out USB Settings or USB cord as the culprit…but the problem persists…

Will keep testing and report back anything else I learn/find…but still stumped here too!


Although i doubt it will fix your problem , since it is so peculiar, it would not hurt to disable usb selective suspend

Yes. I can confirm that I have unselected that option on ALL usb connections.

I also used USBDeview to audit and uninstall any legacy/leftover USB connections.

I then removed and cleared ALL USB connections except for Keyboard and Mouse.

Doublechecked in USBDeview and Device Manager that only the keyboard and mouse were connected and nothing else was “hidden”

I then rebooted the system. Shut it down and reconnected the pedals, base and wheel using powered USB 3.0 ports on MoBo (Red and Blue) as well as a couple other devices I use for racing — Stream Deck + and a 2ndary keyboard.

I checked connections and settings in USBDeview and Device manager to confirm everything was connected directly and correctly.

I also replaced the USB cord between PC and DD Base.

NO devices are run through and external powered USB hub.

Ran another test drive at a different track and car combo — and the Base still cut FFB.

So problem persists. Less frequent and more random when/where…

But USB audit and checks and cord replacement seems to rule out USB ports or cord as the cause.

Also can confirm my MoBo BIOS is the latest version with Correct Agesa drivers/chipset installed.

Still stumped…:face_with_spiral_eyes::face_with_spiral_eyes::face_with_spiral_eyes:

Hmm, that rang a bell, there was an issue with AMD chipsets
Which based on some posts in the linked thread wasn’t completely fixed by update.
And another one
AGESA not fixing USB problems in my X570 5... - AMD Community
and another
Re: Intermittent USB 2.0 connection on AGESA 1.2.0... - AMD Community

Looks like the workaround was to switch PCIE to gen3. May be something worth trying.

I don’t know if this could be caused by electricity. Is your wall socket grounded ? Are you perhaps using any surge protector , or ups ? Could you tell me once more what firmware you are using atm since it all started after the firmware update.

Firmware is in the screenshot way at the top of this thread. It’s the latest that auto install with TD software update.

I have tested different outlets. Don’t think it’s a power source issue. Plugs are grounded. No surge protector or power backup supply unit.

1 Like

I went through all the BIOS and Agesa issues a year ago when this problem happened on another SC base. My understanding is MSI issued a BIOS update that addressed the issue. I ran that BIOS version for over a year without any USB issues. Remember this problem appeared this time after updating the TrueDrive software that forced a firmware update.

Nonetheless, as part of this round of troubleshooting, I flashed and updated my BIOS to the most recent version. So think we can rule out BIOS or Agesa as the culprit.

Still stumped.

1 Like

I don’t know how to do this. Do you have a link with instructions? YT video?

Haven’t read all the messages, there seems to be 110 messages in this discussion. Just to remind or to point out that as long as you’re not contacting our customer support directly, you’re not actually receiving official support answers and/or official support solutions to consider. This discussion forum is not the offical way to get product support from us.

Yes. Well aware that this is not official support channel.

I have opened a ticket with customer support. Last week. I have not yet had ANY official response from SimuCube Customer support on this matter. Just an acknowledgment of receiving my support ticket.

So my only recourse in the meantime is to try the troubleshooting ideas offered here.

Perhaps when SC customer support observes a customer in here with a difficult and unresolved issue (100+ messages) that would be an opportunity to ESCALATE and EXPEDITE the matter for a speedy resolution.

I don’t wish to be critical of SC customer support. I want to give them an opportunity to address the matter…but the silence and delayed responses have been noticeable. :man_shrugging:

I can google for you but don’t know your MB model and use Intel myself. Check BIOS manual.

We are reading your messages both ways, but until we have a good idea on what we do… well its not worth the time to give a “we are still looking at it” comment on it. And we have replied to the ticket, its just that you keep making more tickets which is also slowing us down and not actually helping at all.

The last time you had this issue, we replaced the wheel base and there was nothing wrong with the wheel base when we tested it. So thats one thing we must consider also. Also the failure mode of no FFB in some particular corners is not something that is happening to anyone else in the same way so its difficult to get convinced that the wheelbase is at fault here.

Until you informed me, I was unaware that the “contact us” on your website created new tickets when used.

I only communicated to you there 2-3 times, and have patiently awaited a reply from you since raising the ticket.

In the meantime, I am trying the suggestions here as well as what iRacing and my PC Builder have suggested…I’m using this thread to keep you updated since you’ve asked not to do that via Discord or Contact Us.

When you replaced the base last time, IT RESOLVED THE PROBLEM. So not sure why we have not tried that this time…

My replacement base worked just fine until I updated the TrueDrive software and firmware and the problem came back 2 weeks ago.

I think my efforts to troubleshoot and resolve this have been quite reasonable and comprehensive…and have ruled out any other software or hardware issues causing the problem.

I’ve done everything suggested here except install a new/different sim racing platform I will never use again.

As I said, I’m not being critical…I’m exercising patience.

But for such a premium product, and clear unresolved issue, I’m a little surprised it’s taking so long to get a satisfactory resolution.

If it’s only happening to me should not be a reason not to offer a remedy.

That suggests it is an isolated issue and perhaps a defective base — software, firmware or hardware — or all 3.

My money is on a buggy AMD chipset. Is it the same PC you have used with the previous “nothing wrong with it” wheelbase as well?
Try switching to PCIe gen3, you have nothing to lose at this point anyway, testing with with other PC would be ideal though?

We can rule this out, as if it was a software or firmware issue, then a rather large number of support tickets would be of this same issue. USB interface parts of the firmware were not changed at all in the latest updates, so it is very unlikely. And the low level USB communications run on hardware block on the microcontroller so we can’t really affect those with firmware on the lowest level.

iRacing asked me to change to PCIe Gen3…doing that now…will report back.

Have confirmed that PCI_E is set to Gen 3 in the BIOS.

I can also confirm that there is no OVERCLOCKING in the BIOS and my A-XMP is ‘on’ for both memory slots.

Just ran a test of GTE RSR at Suzuka in an iRacing public practice session – and the FFB cut out 3+ times in 2 laps…so problem still persists…still stumped. :man_shrugging: