SC 2 Pro Driver error

Hi All,

Just got my SC2 Pro setup today and to my horror I am geeting a “driver Error” and windows will not recnogise the unit or sometimes it does but fails anyway.

This means TrueDrive software is not recognising anytihng and I cannot drive at all as a result.

Fresutrated as you can imagine.

Is his a faulty unit?

Can anyone help?

THanks in advance.


Open up the device manager in Windows and see if there are any yellow varning marks on any of the USB devices.


1 Like


  1. Change USB ports, front, rear, USB 2 / USB 3
  2. Try another USB cable for the SC2 Pro.
  3. Check for Windows 10 updates.
  4. Check for Motherboard BIOS update and driver updates for MB.
  5. If you had Logitech, Fanatec or TM wheel before, make sure to UNINSTALL those apps for them, restart
  6. You can also try manually update all the USB drivers in device manager. And also try to uninstall then, restart and let windows re-install them again.


7. Uncheck all USB Power Management. All of them, one by one.



Also check so both power supplies seems to work for the SC2.

THanks @Boska for the help man. Truly appreciate it!

Tried all these and got no where.

I’ve triple check leads cables and pwer supplies. These are all good.

It’s the USB driver for sure. But windows cannot seem to install it correctly.

What motherboard is it, brand and model?

Worst case, u will need to do a fresh, clean Win 10 install… might fix it.

If you have a second PC in the house, laptop or something you could try the SC2 Pro on that one just to rule out the wheelbase.

So I uninstalled and reinstalled and windows has updated the drivers properly.

Now I’m getting a firmware upgrade mode error…grrrr

1 Like

yep not that. wish it was LOL

Intel i7-8700 3.2 GHz

That is CPU, not motherboard.

Interesting issue. What did you do to resolve the first issue? Just reinstall windows?

I heard from Tomo that our forum locked out the OP for posting too much right after registering. I manually adjusted the trust level of @Clarke_S but I have no idea if it enables posting rights again or not :frowning:

1 Like

Thank you @Mika.

I’ve been able to progress a little and now the issue is as the firmware update starts it freezes the applicaiton.
“Not Responding” error at the “unlocking and erasing program flash memory”

I uninstalled the USB and restarted windows and did this 10 times before it worked.

Got the installer to move through to the “Firmware upload proress” section of the update before it freezes!

What could be stopping this from working.

Which motherboard and on which ports on that board your Simucube is connected? Some Asmedia usb chipsets are known to have issues.

This app below can show what MB you have if you dont know.


1 Like

I have no idea how to find that out. Sorry Mac user for my day job.

Gigabyte b360m-hd3

1 Like