Rfactor 2 ( Crash FFB and driving in Walls etc) feels too strong

Dear SimRacers :slight_smile:

I have a Simucbe 2 pro and I am totally happy with the system, it just feels awesome to race.

I mainly play Rfactor 2 and have a question about the FFB settings.
I noticed that accidents with other cars and driving into walls reflects an extremely strong FFB.
That gives such a jolt to the steering wheel that I’m afraid that something will be damaged in the long run.

In other games like Raceroom you can turn off the impact or accident damage, unfortunately not in Rfactor 2. Is there any way to reduce this in Rfactor 2? I’m missing something? I like that the FFB reflects the impact, but I find it clearly too strong, also when other cars crashes in to you.

Car Specific FFB Multiplier is on 0.45 % and FFB minimum Torque is: 0.0%

I would be thankfull for your help :slight_smile:

look for “jolt magnitude” into the .json file and set it to 0, or even better look for Mika’s rev3 file into therF2 main thread in which the value is already set.

2 Likes

thx man. It was already at 0 so i changed it to -2.0 will see how it goes.

ok i tested it even with -10 and i still have very hard jolts when crashing or being crashed. Dont know what to do :wink:

@Raijaa: Change the force in TrueDrive down and compensate by increasing force in your sim.

3 Likes

sry to bother you again, where in the json file can i reduce the ffb settiungs for the curbs? they are also too strong.

@phillip.vanrensburg thank you very much for your answer. which setting do you mean? the car ffb in game or ffb minium torque in game?

I don’t play rFactor, someone else can answer on that. But reducing the TD torque % should feel lighter for you in crashes and wall-strikes, just reduce that first and see how it goes, you can tune the game after.

It works this way in iRacing, just taking a stab at it, but hopefully someone skilled on rFactor will chime in soon.

2 Likes

Hi Raija,

Running similar setup to you, but never had this issue, I do run TD overall strength @ 100%, and rf2 at about 65% for gt3 ferrari. I also set the steering range/Bumpstop range in TD to match the car in real life, and set the same wheel range in rf2.

Bumpstop feel is set to hard, SFRF is set to 3, Damping set to 6%, SFR Set to off, ULLM Set to off.

DirectInput effect fine tuning Damping/Friction @ 3%.

HTH

Jason

set “Jolt magnitude”:-2,

Rumble strip magnitude":0,

“Rumble strip pull factor”:-1.5,

in order for those settings to be saved permanently , game and it’s launcher must be closed

1 Like

Hi Guys, it’s me again. I was away for a couple of days. First thank you for your tips, i tried them all but without success. I realy dont know what the Problem is, but the curbs and crashing in General is way to hard. the jolts i get are not funny. Can some one of you post your Controller ini?

I changed Jolt and Strip magnitude, Rumble Strip, anything you guys suggested but i still have those jolts.

So it would be very nice to test another Controller ini :slightly_smiling_face:

Anyway thank you for your help :slight_smile:

just put it in the folder with all the other controllers , load it in game , bind your controls and then save with a name of your choice. Not that many changes since sc2 pro isn’t available to me to test but just for you to try. Maybe something was wrong with your file.

Try turning ‘static force reduction up’ :slight_smile:

Umm… Impacts (from kerbs, walls or vehicles) are - by definition - not static forces… Turning SFR up is not the way to go for this issue… If it does have an effect on impacts, it’s a side effect - treat the cause, not the symptom.

Reduce the overall strength slider % in True Drive down from 100% to 50% or 60% or whatever you like, adjust game-gain to compensate for force feedback during normal driving.

2 Likes

Any update to this post? Having the same issue and just cant find the solution

SC2 Pro P310 August2022.JSON.txt (43.4 KB)

This is the best SC2 pro i found so far.
Attaching the controller json file (had to add.txt to upload it here). As far as i remember, i only changed the Rumble strip magnitude and the rumble strip pull factor to zero and jolt magnitude which you could decrease to your liking. Things were too harsh so i had to do something :slight_smile: Also remember to adjust car Specific FFB Multiplier to 35-40%. Found 40% is ideal for me.

1 Like

Just seen this (not been in the forum for ages).

rf2 is my main sim.

Where are you editing the JSON file - is it the one in the …UserData/Controller folder?

Secondly - are you reloading the JSON from within the sim. Just changing the setting in the JSON will do nothing unless you explicitly reload the JSON.

FWIW, I run JoltMagnitude at 0.5 and TD at 100% and with very few exceptions, crash events are not a problem.

1 Like

Rumble strip magnitude has no effect in the game, it’s canned effect, disabled in the game…
To smooth the kerb, increase reconstruction filer, I’m trying to have the best FFB, not all at 0%, cause it’s raw, but not really realistic, now I’m playing with Reconstruction filter, Ultra low latency, Damper, Friction, Static force reduction.

1 Like

After experimenting with all the filters, I can conclude I have an “issue” with rF2.
I use 100% in the SC2 pro TD panel.
And with rF2 the perfect spot for me is 30-40% range.
More I have some violent shakes, oscillations, and the kerbs are so much violent.
If I raise the Reconstruction filter, it can reduce the awfull violent kerbs, but it removes some details.
With all other games, I have no issue like that.
There is no way to reduce the violent kerbs only.

1 Like