Restarting DD thomconcept beckhoff engine

I will need your help,
I recovered a thomconcept DD with beckhoff engine and simucube+ioni card,
but I can’t get it to work…
I will need your help to know which firmware version I need etc…
thank you very much i’m lost in all this

What is the controller name that shows on PC? MMOS or Simucube?

1 Like

precisely, when the steering wheel is connected via USB to the PC, and I turn on the steering wheel, nothing is detected

Which USB port are you using on the device?

The two port usb are connected

has this device worked previously? and are you sure that there is no MMOS or Simucube game controller visible?

yes this device has already worked,
but the one who gave it to me,
didn’t know what he had,
when the motor is powered,
there are like “notches” when you turn the steering wheel,
whereas when the power is cut, the axis rotates perfectly,
yes I’m sure nothing is detected at the time of power supply,
maybe a driver problem?
I’m sorry I make videos on youtube on simracing, I had to downgroad my equipment to invest in rallying in IRL,
I had an SC2 before,
I recovered this steering wheel I would really like to make it work :frowning:

Notches would be bad wiring for the servo motor or switched out wires in the motor power connector. But it is a beckhoff motor, I think almost nobody except thomconcept themselves have first-hand experience about it.

It is unlikely to be a driver problem as neither the MMOS or Simucube firmware require any driver from PC side.

Are there any lights on the Simucube board?

1 Like

Yes the led 3 flashing

Anyone remember if a flashing LED was indicator for something on MMOS? Like, waiting for index point? I can’t remember anymore.

1 Like

thank you very much for taking the time to help me

the problem cannot come from the encoder or from the ioni?

can you show your settings in ioni and mmos ?

hello, after spending a lot of time on the problem, I think it’s useless for me to send you my simucube and mmos settings, because the steering wheel is not even recognized by the PC,
and I cannot change the basic settings in the two respective software,
I think it comes from the encoder,
when the steering wheel is not powered, the steering works perfectly,
and as soon as I feed the steering wheel, when I turn the steering wheel, there are big “notches” in the direction,
I tried unplugging the encoder and it does exactly the same thing,
what do you think ?

It can be incorrect setup of some parameters like ‘AXI’ and/or incorrect wiring of UVW Power phases. Most likely nothing serious. So when servo is unpowered, and you turn wheel clockwise, you can see encoder direction increasing, and vice versa?

as I told you I can’t see anything on the PC,
it’s as if the steering wheel wasn’t plugged in

That’s not what I asked though. You need to check inside Granity when connected to the device. There is a status page where you can see the encoder count going up and down - check that and feedback.

1 Like

sorry I’m French I don’t understand everything… is this the tab you want to see?

Yes, check under the last tab….testing….close to the bottom in the middle, there should be position feedback counter. It should Ho up in clockwise direction, and count down in counter-clockwise direction.

If that is working, we can move onto next step…

1 Like

hello, no nothing changes in testing…