Replacing Simucube Board


I had a simucube boarding that I believe has failed, I have a brand new board purchase before that I swapped, now the board will connect to the PC as I can here the USB Chime,

I have connected the wires and swapped in the IONI Board,

I hoped for Simucube to pick up the new board but I get the following message

There is also a LED Light flashing as seen in the above video Screenshot 2023-02-20 at 17.38.22

Prior to this I did look at my preouus forum and did follow some steps by downloading the bootloader software, but then stopped as i dont think it is needed due to the board not being in DFU mode.


Please could you advise on how I can get this live, my computer is on remote if need any questions



I can’t help you today on this, but is that a yellow exclamation mark on the STM32 Bootloader device? What does the windows complain about it?

i couldt find a way to run trouble shoot, but i right clicked

select properties and screen shot the following, the drivers for the following device are not installed

The driver should be available from the directory where you installed DfuSedemo to.

From the website

From the Simucube download

To Clarify, I need to update driver with one of these files?

I also dont see DFU Mode on the Dfsu Demo App

Please could you break down the step I need to do to fix this for Simucube to find the device


Check the C:\Program Files (x86)\STMicroelectronics\Software\DfuSe v3.0.5\Bin\Driver

directory. Could be another version but its there. Point Windows to try to find the driver from that directory.


Thanks for the suggestion

I am still struggling with doing the above, I completely swapped the Simucube board with a known working one and had to swap the IONI Board, worked fine with the wheel

When I then installed the same IONI Board onto the brand new Simucube same fault as before

I have now taken home the board with power supply unit and USB cable

Would you be able to breakdown in a few steps simply in how to get the new board working, I have looked at the guides online but couldn’t not manage to do it successfully.

If I can get the new board configured to work with the existing IONI Chip then I should be able to use my wheel.

There’s a definite fault with the old board hence why now trying to get the new board working

Thank you


Would you be able to advise?

Thank You

Contact us via the support, thanks.

Just an update, iv taken home just Board and PSU,

Used my old windows 7 laptop and see straight away
STM Device in DFU Mode.

Is this why simucube configuration tool can not see it,

do I now need to flash the IONI Drive, would this be the correct method

Or do you advise previous boot loader method





I re followed the steps and uploaded boot loader through DFU mode and now Simucube sees the device

I now have the message hardware settings not yet set

Could you assist in the last step in getting the wheel to connect,

How can I resolve the issue

Thank you

You need to run the motor configuration wizard.

What is the motor , Psu , encoder to help you out.

I think he has a working IONI board to use with this, so no configuring of motor settings needed. Just click ‘use existing setting’ in the motor wizard and click next until it finishes.

1 Like


Thank you, this has solved the issue.

A new problem occurring is

Simucube configuratior keeps crashing

When playing I can hear the USB remove chime,

Project Cars will sometimes crash along side it too,

The moment I unplug the USB Cable for the wheel everything works back as it should,

Me thinking is incorrect driver installed?

  • the board was set up on a windows 7 Intel laptop
  • this specific PC running the game is windows 10 AMD

Is there a way to force the correct driver to be installed or have I corrupted or have wrong driver installed caused the computer to crash

I have attached images / video below

Some type of USB issue. Try with different cable, different USB port on the PC.

Simucube X3 USB port (the left port) does not require any drivers if the Simucube firmware is installed.

Hi @Mika

I have tried but same issue,

You can see in video 1, as I sit in the wheel USB disconects and the wheel is pushed with force to the right max even with the USB chime disconenct

as soon as i disconect the USB computer is normal, when i plug in and wait 2/3 mins after half the race againe chime and disconnects

It freezes, even when configuating FFB settings it will crash

I need to unplug simucube and connect back to pc for it to pick up,

Only after restart PC Windows gave me the code 43 Problem,

What Seems to be happening software is ok, but when the Hardware is connected to the computer it causes a crash, its the first time issue like this is happening

This is the Only AMD Pc with have compared to the others,

Video Link

I will make some other comments

  • I set up this new board with a windows 7 laptop Intel

  • I have noticed a random spark on the bottom of the foot pedals, does the simucube wheel need grouding? is this causing a short hence why the first board blew?

  • I Have disconnect the foot pedals and still have same issue with usb

Is there any suggestions to help find the problem,
do i need to reflash the simucube board
should i connect the board to another sim
should i swap the IONI Board

Maybe this fault someone else has had and they found a way to fix

Thank You


Update -

You are correct there is a USB Issue, what’s been happening after first use the USB ports start disconnecting and stop working.

I then used a brand new PC worked fine at start and then USB Stopped working and motherboard died.

What seems to be happening the USB ports are blowing the PCs,

The PSU Unit used on this simcube I have not checked the values yet, waiting on voltmeter to arrive.

My question to is.

Is there a way the Simucube board is overpowering / shorting the PC , what can we do to fix / prevent this.

I would also like to order x2 wireless receivers for simcube Boards, please advise on ordering process

Thank you