Problem with Premium Torque Button

Hello,

I upgraded my SC2 Pro with a Premium Torque Button (to have a on/off switch beside me) but it doesnt work as it should.

I cannot turn on or off the SC2 - the blue led is blinking a little or is at full light but is not having any function.

E-Stop works as it should - but as I am using a steering column and the SC2 being somewhere near my feet I only bought the premium button to have this switch…

Any thoughts? Anything I need to configure…?

Thx!

Could it be that the on/off switch on the back of the SC2 must always be on in order for the on/off switch on the premium torque off button to function?

The switch on the sc2 s basically on but the button on the premium torque switch makes no difference.

The switch on the SC2 has to be off if I remember correctly.

1 Like

I thought the Premium on/off switch only worked on the Ultimate as ultimate does not have a on/off switch only on the PSU.

Try it with on and then with off on your SC2.

We are working an issue where due to some tolerances of components the switch does not power off the device as intended if connected to Sport or Pro. It is the next thing to investigate further after the wheel going one revolution wrong -issue.

1 Like

Hi Mika, thanks for the feedback. Is this something you‘re gonna fix with an firmware update or would I need to swap the unit?

Best

andre

Granite Devices team (Mika)

We are working an issue where due to some tolerances of components the switch does not power off the device as intended if connected to Sport or Pro. It is the next thing to investigate further after the wheel going one revolution wrong -issue.<<<

I ordered a PREMIUM KILL SWITCH with BATCH 3, as an upgrade from my reseller, but did not receive it, and with no communication from them. What should I expect with regard to availability? I understand there are issues with it when connected to a PRO model.

Hello, just want to state that since the new firmware update the on/off seitch works perfectly :+1:

2 Likes

I have the same issue, that the user powerslide described in his initial post. Even after upgrading to the latest servo drive firmware 10809 and truedrive 1.0.10. Pushing the on/off button results in the blue light shining brighter/darker. That’s the only thing that happens. What can I do?

It should work with the power switch in the “Off” position - can you try it?

You are right. This way it works. Thank you very much.:+1:

Just recieved my SimuCube 2 Pro (R2) and bought the Premium Torque off button for the remote power on and off, and ofc the looks of it. :smiling_face_with_three_hearts:

I have tested it and it’s a really nice upgrade from my SimuCube 1 Large Mige with a Sincos encoder that I really liked.

The only “problem” is that the Premium Torque off button has no function, only the Kill function.

When I click the On/ Off switch, it goes from shallowis blue to more bright blue but does nothing, then I read Mikas comment to set the Power switch on the motor to off, but that does nothing, the Premium Torque off button is not doing anything, even if I disable the kill switch, the system is not even turning on.

I’m on the latest firmware 2021.1

Hi Buresoe

Did you try the premium e-stop power switch directly after turning the switch at sc2 back plate off?

Please try it so, that the sc2 unit is completely shut down, and then hit the premium e-stop power switch.

Kind regards,
Esa

Hi Esa.

I was just about to write back in here, that it’s working now.

Guess the only difference was that I didn’t touch the rim after turning on the motor for some minutes while I did some work on my other pc, and after a few minutes it made some sounds, and I turned the power off again on the motor, and this time it stayed green on the plug, and I could see the Premium e-stop power switch was not lid up, so I pressed it, and it turned bright blue, and a few seconds later the motor sounded with normal start-up blip, and then all I had to do was start the software, and I was gtg. :slight_smile:

I have no idea of why I could not make it work before, but now I know I can just do at you have described.

Thanks for getting back with a solution.

I have a very similar problem on a SC2 Pro R2. The power button on the premium Torque box doesn’t do anything and the base always stays on. I have to kill the power at the power strip. The power button on the premium torque box changes from dim blue to bright blue, but never off. This happens regardless of whether the rear switch is in the off or the on position.
I’ve tried using the regular torque box but I’m getting a very similar behavior. The unit doesn’t power off independently of the rear switch position.
Otherwise the unit is working fine in every other regards.

Model: Simucube 2 Pro
Software release: 2021.5
Firmware version: 1.1.15
Servo Drive firmware version: 10827
True Drive version: 1.1.17

Turn the switch off on back of SC2. I think if that is on, the premium e-stop will not power it off. At least this is what I experienced with my SC2 Pro R1.

It’s off already. I get the same behavior whether the switch on the back is “off” (as it’s supposed to be) or if I try with it “on”. It doesn’t make a difference and the base is always powered.

Hi g33km4m

Is your system still always on?

Kind regards,
Esa

Yes, unfortunately it still is.