Problem after Win10 update + noise coming from motor


#1

Hello guys, so a couple of months ago I got an OSW 20nm - small mige - biss-s encoder, all went smooth and well since a couple days ago, when I got a Win10 update (version 1809) that basically messed up the feedback of the dd. Basically, the force feedback lost its fidelity and also a bit of its overall power, and I can hear a hissing noise when steering the wheel.

When I felt there was something wrong, I opened Simucube configurator to check if some values changed; I opened the wizard to set motor, encoder and a pop-up showed on the screen telling me something like “that version of the configurator is too old, you need to update the firmware”. I have done already some other times that procedure - mainly because I installed the simracingmachine base-side adapter for fanatec wheels - but that was the first time it was telling me to update the firmware.

So I moved from 0.11.0b (the one that was installed when I received the base from you) to version 0.11.02. Also, I checked Granity, and when I saw the values of coil inductance/resistance I remembered they used to be both greater for the older motor, and I thought that was the cause of the problem. I therefore performed the auto-setting for coil inductance-resistance, and at that point started the hissing noise coming from the motor.

So, I wanted to return to the previous values for coil ind/res. so I uploaded the .drc file for biss-c encoder / small mige : the values returned exactly as before but that sort of white noise remained.

(this is the drc file I uploaded via Granity, I found it into the official guide available on simracingbay website :

Since the day I received the new motor, everything went really well, I kept on updating regularly the drivers of my PC, but now, when i check for the available drivers on the Dell web utility, it keeps telling me I need to update the Intel Chipset, every time I do the search for drivers it is missing…there is clearly something wrong.

All that said I want to ask,have I done something wrong with the firmware / drc file for the Simucube? Do I have to return to the previous firmware, the lates stable 011.0b? What can be the cause of the hissing noise coming from the motor?

Thanks to everybody wil respond.


#2

We do not ship with Simucube firmware installed.

These can be a source for hissing noise from the motor. Also you can set the Torque Bandwidth Limit in Simube to lower, to mitigate this noise.

The latest stable version is 0.11.2, previous versions are not supported.


#3

It is my feeling that you haven’t changed settings by yourself and that a Windows update cannot have caused this to happen, as a Windows update can’t change the Resistance and Inductance settings inside the servo drive.


#4

Hi, I know Simucube is not shipped with firmware installed, in fact I got the Simucube back from assistance from Tomo because I had some other problems with my older motor, and I got the Simucube back already with firmware installed by Tomo along with the new encoder - before I had sincos.
So, why does the screen with the advise of updating the firmware appeared right after the windows update and never before? Did I followed the right procedure by uploading the right drc file on Granity?
Also, why I am having now this noise, and it never happened before?
Thanks.


#5

This I can’t explain.

You can upload the DRC file in Granity OR in Simucube, as long as you run the Motor Configuration Wizard again if you have made actual hardware change.

Maybe you now have more accurate MR and ML settings than you had before, or you have higher Torque Bandwidth Limit value. Also, the routing of the servo power cables can have an effect.


#6

If you think that it is windows related , either do a format and reinstall windows , or a better solution is to test the wheel on another computer. Because it is not that easy to move around the wheel , just bring a laptop and test how the wheel performs.


#7

So, there are my Simucube and Granity settings…
By lowering the max voltage from 51 to 49 it seems to have mitigated the noise, still the feedback is not as it was some days ago…now, before I am left with the only option fo reinstall Windows 10 by scratch, I would like someone to take a look at those settings and tell me if something is wrong…thanks.


#8

Fov could be at 49.5 but i doubt that is your problem.

So basically you are using the same drc file only with lowered fov and you still get hissing noise and different feedback. Did you change any settings in simucube , or in game ? The feel changed only for 1 game , have you tried others ? Can you explain what you mean different , in what way ? Minor differences or you can’t drive ?

If 10 days of the windows update haven’t passed you could uninstall the update.


and see if that helps.

Other reccomendations would be to set Fov at 49.5
Try MR 2.6 & ML 11.5
FBST 21


#9

Hi,
to recap the situation : I received my simucube with brand new electronics + a brand new motor 20nm with new biss-c encoder not more than 2 months ago from Tomo, I had another problem with my old osw for which I needed direct assistance.
Everything went smooth and fine untill last week, when I was normally using my gaming PC for other stuff and in the meantime there was this update downloading and installing.
Once the process of update terminated, I had normally to restart the PC, so I did and once I started back again I switched on SImucube to play; I remember I entered into a session on iracing and I instantly felt there were something much different than before.
I try to explain the best I can : before that happened, therefore since I got the osw, the force feedback was clear, strong and crisp in every game, just like it should be, but now it feels generally dull, softened, and when I am steering I can clearly feel and more than that I can clearly hear this hissing noise coming from the motor, which impacts strongly the force feedback with something I can describe as a sort of heavy damper effect.
In little words, force feedback is no more clear and crisp, I think it has retained its overall power but with this constant damper I can’t say for sure.
So, when I noticed all that, I started looking into simucube profiles, games settings and granity to see if something had changed, because I am 1000% sure I do not change anything at all, first of all I never touched nor opened Granity since when I got the wheel, and also I never changed any game profile on simucube or any ingame setting.
I must say - as I stated in the other post - when I powered on Simucube for the first time after the update, I thought all of this had something to do with the encoder calibration, therefore I wanted to start the wizard for encoder calibration, motor setting and centerpoint, and in the very moment I clicked to do the process it showed another window telling me I had to update Simucube firmware to go on with the process, and that was one thing had never happened before since I got this wheel.
In conclusion, I thought to do everything in my power : I uploaded .drc file (the one I found on simracingbay) for biss-c encoder - small mige, I done again calibration for the encoder and centerpoint, switched usb ports, also tried every single game - ac, acc, rf2, ams, r3e, iracing, pcars2 - and all of them felt very much different than before, maybe the one in which I am feeling and also hearing the most this hissing noise being AC.

I really don’t know what to think.
The only thing I could think of is this, although it is really unlikely to be correct : I bought the older motor last october, I got it second-hand from another guy who sold me motor + simucube + cables. As I said before, after a couple of months I needed to send everything back to Tomo, and last january I got back my old Simucube with new Simucube board + new Ioni, but the only element of the old case that I still got is the power supply : I am no expert by any means, but is there any chance that the issue could be caused by that psu? is there even a way to test it?

ps. you suggested ML 11.5, didn’t anybody suggests to actually lower those values to mitigate the noise?

Thanks a lot for the response, tomorrow I’ll try to uninstall the update, it’s not yet 10 days.


#10

You changed the values of mr and ml to lower values and the hissing noise you said raised. You lowered the fov and the noise was lowered. None of these should have that impact. The values i told you shouldn’t also produce noise. Lower the damping direct and ioni to 0 and see if it had any impact. Uninstall the windows update to see if the feel comes back and you ll see from there.


#11

The servo drive and its parameters do not have any knowledge about windows - they would operate the same even when connected to Linux, or when not connected to PC at all. So I think @alessandro85 is chasing some change that just is not there.


#12

Btw what psu is it? Do you know the model?


#13

that’s the best shot I can get of the psu


There’s one thing I forgot to ask, when I received the wheel, the max Amp were set at 12A; now, when I upload the drc file all values in granity corresponds exactly to the ones I had when I got the wheel - I took some pictures of granity tabs to confront the values - except for the max Amp being 12.90 in the drc file I found on simracingbay page. All the rest is the same, also for MR 2.240 and ML 6.505. As fot those values, is it better to keep the one that comes with the drc file or is better to do “,easure resistance & inductance”?


#14

@Mika I wouldn’t been loosing time claiming something that isn’t happening for real.
I think to have sufficient experience with simracing hardware - not as much with PCs in general - to know how a direct drive wheel would behave. Also, if I wasn’t really frustrated to have spent well over 1.000 euros for something that it isn’t functioning properly just after 2 months, I wouldn’t been writing here in this forum, believe me. One thing is clear to me, if I won’t be able to solve that issue in about a couple of weeks, I won’t keep an expensive piece of furniture taking dust in my room, and I will definitively sell everything of my simrig.
So please, if you may have an idea on what’s all those problems about then I am very interested in hearing any way to solve that issue, but please don’t tell me “I am chasing something that just is not there”.


#15

My apologies. But in any case, a Windows update cannot have caused this.


#16

So now you have mmc at 12 or 12.90 ? I would suggest trying even lower amps for testing , mcc 9.5 and mmc 10 . The best way to set mr and ml is the Manual tuning method that is writen here https://granitedevices.com/wiki/Tuning_torque_controller . But it is not that easy to do that. So automatic measurement of inductance and resistance is easier , but i can’t tell you if it is most accurate , not atm at least. When you do some testing with anything report your findings.

also have you checked your simucube and ioni for any signs of damage ?


#17

I uninstalled the win update, same as before, nothing has changed.
as for damages, just a tiny scratch on the plastic of the back of the case and nothing else.
one thing, is it normal that on the connect page of granity is reported “this info updated only after connect” on the Firmware revision ID?
Annotazione%202019-03-20%20222535


#18

yes, that is updated once you have a connection to the servo drive.


#19

about the feel , did you try on another usb port ? how is your wheel connected ?(directly on a usb 2.0 or a 3.0 , or maybe via a hub) Have you tried any granity changes ? Seems to me like something isn’t working properly and from the info you are providing seems like hardware , but checking some software parameters can’t hurt and hope for the best.


#20

@Mika ok, but I had just connected, otherwise all the other numbers - serial etc. - won’t show up.
look, this is before connection :
vedf
and this is after :
afff
@Loukas_Bourdas yes already tried changing usb port (it is connected via usb 2.0), and also all granity vhanges you suggested.
I just inspected the case and only thing I found that can be relevant to note is that both pins that serves as insertion for the connector of the encoder have both stuck to the connector of the cable. see there :