No FFB in Simucube 2 Pro in iRacing until wheelbase reboot

Hi All,

I’ve been enjoying my Simucube 2 Pro immensely for about a month now and have had no issues with it until the last few days. I’ve noticed now that when I join an iRacing session that I have no FFB, although the wheel angle input is detected properly by the game. I now need to power off the wheelbase and power it back on, wait until the high torque mode is enabled, and only then I will have both wheel angle input and FFB working. I hadn’t changed anything in the TrueForce app settings before the time when this issue began.

Has anyone else experienced this? And is this indicative of a hardware fault?

Thanks in advance for your thoughts.

This is usually caused by the FFB commands not getting through to the device when the game starts.

I’ve seen this happen to me once with the new NOT BETA UI, but I run a development firmware just now with some USB stuff rewritten so can’t say for sure if the issue is with my firmware or iRacing…

Typically this used to happen if SteamVR was launching and keeping USB bus too busy / locked up just at that moment when the game sent the create FFB effect commands to the device.

Solution is to go to iRacing Options, uncheck FFB, close dialog, and re-check FFB checkbox. No need to reboot the device or to quit/restart iRacing.

Once we have confirmed / proved that this really is an issue with the NOT BETA UI, we will need to discus with iRacing on what is actually happening…

1 Like

I spoke with David Tucker about this not that long ago.
I have an old SC1 customer that is having problems when iRacing switches from practice, qualify and race. He was losing FFB in between the sessions.

Below is David’s response:
From: [David Tucker]
Subject: Re:FFB dropping out behind sessions.

Any time they exit the sim and come back in (Say when being pulled from practice to race) we have to reconnect with the wheel and there is always a chance that this will fail. When it fails it is usually silent, that is we think we are talking to the wheel but it is no longer responding. Exiting the sim is one way to fix this, the other is to go into the sim options and toggle FFB off then on again, They may need to exit the options screen between toggles.

The main reason this happens is because they are using a VR headset, there is a known issue with SteamVR where they sometimes block us (and all racing games) from accessing the wheel as they start up. The workaround is to start SteamVR up first then launch iRacing.

Another common issue is just having too much traffic on the usb bus. Modern FFB wheels try to communicate at the limit of the usb bus (1 KHz) and since the bus is shared it is possible for another high volume device like a usb sound card or vr headset to saturate the bus and cause the wheel to loose communications packets. If that happens at just the wrong time the wheel can miss our request to turn on force feedback. The solution here is to isolate the wheel on its own usb bus. The simplest way is to pick up a pci usb card just for the wheel, although you can play around with moving the wheel to different usb ports on the motherboard to try and get onto a separate usb controller.

I tried the trick of turning FFB off (exiting settings), then back on, and it doesn’t fix the force feedback. I definitely need to turn off the SC2 via it’s power switch and restart.

I do use Oculus VR (Rift S), and don’t run iRacing via Steam.

I do use irFFB, which may or may not be a complicating factor (it’s been working fine).

I’m experiencing the same thing except last night it happened in session after I had to spend a bit of time in the pits. It also happened in my last team race when I came in mid-race and no FFB. I’m not running VR. Turning FFB on/off does fix it but that’s not really a valid option during a race when you don’t realize you don’t have any force unitl you are moving and have left the pit stall. I’ll try what David suggest with the dedicated pci USB which I have.

I get the same issue in rfactory 2 at times.

hello I also have a similar problem with my simucube pro for 2 days, I do not go through the iracing beta but not the web page, it happened to me 2 times that the force feedback was zero while the high force was activated, no fault notified, I had to cut the simucube by the switch to find the ffb.

Same problem here, occasionally. SC2 is on, TD running, iracing running, all settings correct. No FFB. Hard restart of SC2 fixes it.

Most of my USB issues went away with the introduction of a USB dedicated PCIE card, 4 separate controllers and now, “touch wood” all those USB funky random things have departed.

1 Like

Update to this thread:

I’ve had no additional FFB dropouts since installing the latest Truedrive software and SC firmware from the October release:

Perhaps some change in that version addressed the issue? I’ve made no other configuration changes that would have accounted for the behavior improvement.

I have something similar to this with my SC2 Pro. I get no feedback at all whenever I join a session from the UI. If I join from the webpage it works fine.

Has anyone else seen this?


Software 2021.8
Firmware 1.1.33
Servo Drive Firmware 10829

Are you using SteamVR by any chance?

I have it installed - but I’m not “using” it. I don’t access iRacing through steam etc.

I uninstalled SteamVR, and it seems to be working now.

Thanks Mika!!