New Simucube Pro bricked with firmware update error - True Drive 2021.4

I’m feeling a bit devastated. My brand new, never used, Simucube 2 Pro is dead after the firmware update on first launch. “Drive firmware update error. Turn system off and on again.”

I downloaded the Simucube 2 True Drive 2021.4 software after bolting everything down, and plugging it all in for the first time. Upon launch the True Drive software notified me of a Firmware update and I allowed it to do it’s thing. Once it was done the True Drive software simply closed. No warning or anything. I waited to see if it would open again by itself, but nothing happened. After I relaunched the software I saw the firmware update error message at the top of the window.

I attempted to download the previous version of True Drive and all I got was a message that my Firmware was too new. I’m not sure what to do next. I was so excited up until this point. :cry:

I’m running Windows 10 with the latest patches. My PC is custom build with a Ryzen 3900x, 32GB Ram, Asus Tuf Gaming x570 Plus (WiFi). I think the mobo bios is 3204 from earlier this year.

1 Like

Relax, it’s fairly simple to downgrade fw to working condition. These SC2’s are extremely robust and very simple to recover from mishaps. I have done crazy things over the years with them, never managed to brick one.

See my post 2 here: New Owner SC2 Pro ~ small issue? - Simucube 2 / Simucube 2 Questions - Granite Devices Community

Follow Mika’s basic instructions from that link in my post.



I literally just found that and it worked. I came here to post success. :slight_smile:

Not sure what happened with the new firmware. I might give it another try. Gonna attempt to play with the new toy now. :smiley:

1 Like

So I decided to give 2021.4 another try now that I know how to downgrade. I ran into the same issue. There’s something up with this version. I’m on 2021.1 again and it’s working.


Strange issue, thanks for reporting it.

1 Like

It does not seem to repeat on my revision 2 unit :thinking:

1 Like

Mine updated ok (Pro R2). Was running 2020.10 before. Will do a longer session later to thoroughly test it.

same problem as novopaine with 2021.4

on sc2 pro rev2

1 Like

@novopaine and @Alex93 - can you please send the device identification information from the True Drive? it is available to copy to clipboard via a button on the last tab in True Drive.

1 Like

Had the same issue today, after a windows reboot, everything just worked fine.

I might have found the reason for this, and as we know the users that can repeat the issue, I’ve given them a link to test package. I’ve also pulled the file from the wiki, as it appears that the randomly selected free file hosting service is banned/blocked in Italy or something, with large warnings. LOL. Friday was not my day…

1 Like

my sc2 pro r2 wont update. ive tried its still 2021.1

Hi Jason,

What did you do to update? Did you launch the True Drive from the 2021.4_2 extracted zip file?

yes, do i need to uninstall the previous firmware first?

sorry for multiple replys and the pics, i am noob with computers

From what I’ve seen, you just run the new version directly from the new folder you extracted everything to. Nothing actually gets installed in windows (as far as I can tell), with the exception of firmware on the device when you run it.

Maybe try putting the file somewhere else on your harddrive? I’ve never been a fan of running programs directly from the download folder. Also, make sure you’re running the new version and not clicking any shortcut you might have put on your desktop as that would simply run the old version. That might seem obvious, but I’ve seen people do worse things. :wink:

2021.4_3 was posted today. I’m going to give that one a try myself in about 1 minute.

Hmmm. I guess 2021.4_3 has the same firmware as 2021.4_1 that I installed already as there was no firmware update initiated when I ran it for the first time.

One comment, the pop-up I got at the start still said 2021.4_2 instead of 2021.4_3.

Software release: 2021.4_3
Firmware version: 1.1.12
Servo Drive firmware version: 10827
True Drive version: 1.1.13

I might have missed to update the changelog file to actually read _3. A minor issue. And yes, there was no firmware update associated with the _3 version.

Just a heads up maybe someone else runs into this:
On a fresh windows 10 install, on"Simucube 2 True Drive 2021.4_3" when I tried to run “Simucube 2 True Drive Classic.exe” it was not starting and was trowing some missing dll warnings, to overcome this you have to also install “vc_redist.x86.exe” that is also in this zip. I mean, it’s probably obvious to most users, but well, you never know :slight_smile: