New SimuCube build doesn't to connect to Ioni

I tried with Dfuse demo and smt32 doesn’t appear :roll_eyes:

You have to move the dip switches, and also verify that Windows is using an up-to-date driver for the STM32 Bootloader

Yes, I’ve tried all that, I’ve been trying for a month, day after day, I install the stm32, with the Driver hub tool, and also manually,
but I can’t access it in granity, nor dfuse demo

Lets try to solve this via remote support - I’ve PM’d you.

i need move two switches or only one switche?,to put in mode dfu i move only the switche number one ,
it is right?or wrong?

The other switch is not connected to anything, so move both -> you will always move the right switch as well.

Erm…I think you are confused where dfuse connects to, and where Granity connects to.

Dfuse is a tool to flash the USB HID (stm chip) via X3 connector. After bootloader is done and FW flashed, this is used as the ‘gaming’ port connection to your pc.

Granity connects to IONI via X4 connector. Typically it is used by power-users only after Simucube USB HID FW is flashed…no real need for regular users to access this.

If you can’t connect to the Ioni after enabling the right button in the tuner window, then you are also missing the UART driver…

Apologies if you knew all that, I just thought I’d posted this to make sure you know there are two main components and interface-channels in play here.

Anyway, please show screenshot of all devices under a Control Panel /Devices. Let’s see what is missing. Sorry for interfering, Mika, I’m just trying to establish base starting-point…

Yes, I think you are right, I am confusing the situation, I do not have enough knowledge, I think, I have tried with both but I am sure that I am doing something wrong, I usually ask for help at the last moment, for this, I am not prepared. :cold_sweat:

Mica, I think phillip is right, I’m doing it wrong

Hi Mate,
That is to detailed, plus I need to see what is under ‘Puertos (Com y Lpt) Anyway, I meant the devices in Control Panel/ Hardware and Sound/Devices and Printers -> so just those bigger icons under Devices and Printers, please.

He had somehow a microsoft mouse driver on the serial port for FTDI. Also, the DfuSeDemo did not find anything with the supplied driver, but the 2012-dated driver enabled that and we flashed Simucube bootloader.

However, neither of the Simucube firmware versions (0.11.2 nor 0.50.4) were able to communicate with IONI after very initial phases of device start. Also, Granity didn’t find IONI at all.

We will attempt some more debugging tomorrow - I already disconnect a session with the user.

Initial suspicion is that there is something interesting in IONI 1.7.12 that made this happen, but unsure what it is as I have even newer IONI development firmware which definitively does not suffer from the same issue.

Hello Mika,
Yes,I suspected FTDI driver was partly to blame, hence asking for screenshot of Devices.

I am not sure if you have tried, but I ran into similar situation few weeks ago when I shipped configured Simucube for Joe Sullivan, also on latest Ioni FW.

How I recovered was to go back to 0.11.2 bootloader, but I used the one which resets/clears all previous settings, flashed that via dfuse and then proceeded with loading 0.11.2 FW. After this, comms to Ioni was restored :wink: Just using normal bootloader left me with the same situation you are now seeing, so give the other one a try if you haven’t

We actually did already flash the “simucube bootloader_and_reset_all_settings.dfu” from 0.50.4 package, it should be the latest and does work the best, and then install 0.11.2 firmware.

Next step, as per my reasoning, is to make sure that Simucube firmware does not start at all.

  1. launch 0.50.4, it will prompt to update.
  2. when updating, immediately after it starts to send data POWER OFF. This will leave firmware corrupted in Simucube.
  3. Close Simucube software
  4. Start Simucube. Simucube bootloader will start, notice corrupted firmware, and stay in bootloader. It will release the USB port for Granity. Should be able to connect via Granity as per any of our IONICUBE systems, and then it should be possible to downgrade to 1.7.10 IONI firmware.

Yep, sounds good reasoning, should work. Of course, that is why I keep old ionicube system ready, for such hard-arse cases :joy:

Edit: Would be a good idea to add some bit of code that we can add as a starting-option when launching the exe, to interrupt process and switch Simucube to bootloader-mode

Such options are in the Simucube 2 True Drive software and are being brought in the next Simucube 1 release as well.

Yep, hence me mentioning it :joy:

But thanx heaps for your efforts, Mika, very much appreciated!

1 Like

Hi, I have problems with Simcub I do not upload files to ioni and in Simcub I am blinking red

Hi Phillip, I see that you have already talked with Mica about the problem, you know much more than me about it, please if you need any more information, screenshots or any specific data tell me, I tell you the same as Mica, thank you very much for your help, my OSW child is sick and needs help :sweat_smile: :joy:

Ha, all good, phoenix, no-one more qualified than Mika to look into this. I’m just throwing some ideas based on my experience, but he has checked them all.

He will get you sorted, no dramas :wink: