Mmos not working with stm device


#1

Hello, I recently got an stm32 and loaded the hex file with stm utility software. After I loaded the hex file I opened up MMOS (With both usbs connected) and there is still the red usb icon in MMOS. I tried plugging in to different ports and still nothing. What should i do?


#2

Try upgrading the board’s firmware first.


#3

I have tried upgrading the board’s firmware it did nothing


#4

Can you give more info about your gear


#5

stm32f4 both usb ports are plugged in i dont have a granite device though i was just asking here


#6

have you configured your servo correctly ?


#7

Yes, it worked before but now it doesnt


#8

Does the encoder still work - i.e. the position feedback value is changing in Granity as you turn the wheel? If not, then the encoder has an issue. If yes, then the MMOS has some settings wrong / lost its config, or something like that.

It is also possible, that MMOS would stay red if you have “use encoder index” enabled there, and the encoder (or cabling) has an issue where it does not give the encoder index point signal anymore.


#9

The encoder works the value is changing. Any other ideas?


#10

At least the newer/latest revisions of stm32 Disvovery is not supported by old MMoS FW. You can get a Core407V and try that, I have used them before.

Of course you have to make sure to use the correct pins then, as the physical layout is different between Discovery and Core407V.

Cheers,
Beano


#11

The weird thing is that it worked before but now it doesn’t


#12

Ha, that might not be it then, your opening post was somewhat ambiguous.


#13

You say you do not have granite devices gear.
What type of servo control do you have hooked to the STM?


#14

It’s a pcb that my friend helped me design. It worked in assetto corsa before


#15

I bought a new discovery and im gonna see if mine is broken


#16

I remember we had problems trying to flash the newer discovery boards.

There is a guy in Australia that came up with a break out board that you could plug the discovery into. I think he had a new sequence of flashing the boards which is successful. I wish I could remember his name.


#17

Like said, the Core407V’s works fine, I have tested them quite extensively.

The newer Disco’s can be flashed with the MMoS FW, but they do not work, there have been structural changes to the u-processor.

Cheers,
Beano


#18

Was it a shield for the discovery?


#19

It is a breakout board for designing prototypes.
Some have been designed for specific functions.
Below is just one example.
https://www.mouser.com/m_new/mikroelektronika/mikroelektonika-stm32f3f4-discovery-shield/


#20

i thought that STM32F407G-DISC1 works too