Looking for some assistance

Hi there
I hoping that some can point me in any direction here.
I have a had a flawless run with the augury 30nm kit for around 3 years but within the last two weeks a strange problem has happened.
A lot happened in this period, new rig, windows updates and simucube Fw to latest.
So here is what’s happening , there seems to be a number of them, the first is, twice now while at the desktop the wheel has rotated left with an audible sound from the servo and is hard to turn right, you can feel the noise through the wheel. activated the e-stop, Restarted fine. While in ACC driving at some point I can feel the same “noise” and some friction through the wheel, then I lose ffb and steering , USB audible disconnect noise and simucube is rebooting itself. I’ve made no changes in granity , so far I have checked all cables , usb save power
option unchecked,reloadedd my Drc file through the configuration tool and ran the configure motor, encoder and center point, same issue happens, made sure bolts are not loose on the biss c encoder . Checked earth cable is attached to bolt on servo and to the rig and to the augury, e-stop is functioning correctly, No fault code is in granity except 481001 which is normal and can be ignored?.
No error is showing in simucube configuration tool. I have done the normal things , changing usb ports and cables. I don’t think these would cause the simucube to reboot.
I’m not sure if a Windows update could have caused this or the update to simucube Fw 1.0.24 and then to fw 1.0.25.
Pretty lost as what to do next, any help would be appreciated. Sorry for long text, I hope I have explained it well enough.


I believe I’m having similar issue as you are, my Augury 30nm constantly loses connection and restarts. I’ve tried as much as I possibly can to fix it but no luck.

I did notice that the day it started happening a couple of windows updates (KB4571756 and KB4576478) had installed, maybe it could have something to do with them. Sorry it isn’t much help but I will keep looking and let you know if I find anything out.

Hi man
Yeah it’s very frustrating, I’m talking to augury trying to find a solution, I hope we can find the issue and a fix.

Best of luck with Augury, hopefully we can all find a solution!

I’m not sure if it has made any difference but I have just completely updated windows along with the new feature update, and enabled the USB Recovery support in Simucube Config Tool, and have managed to do a 3 hour driving session with no cut-outs… Not sure if its a permanent fix but I will give it a few more hours and see if it disconnects again. I’m also running VR if that’s any help as I know they don’t get along sometimes.

Something to try at least?

Thanks for the tips, my fingers are crossed for you. I don’t see a usb recovery option in my simucube configuration tool.

Hey there, I’ve left it on standby all day and playing on and off, still hasn’t disconnected yet but I’m still not 100% sure. Which firmware are you running? for me the usb recovery is under hardware setup, just above the configure motor and inputs buttons.

Yep, got it, will be testing over the weekend and see how it goes

Best of luck, hopefully it will help a bit. Make sure your windows has the feature update also just in case… Let me know how you get on :smile:

Found this thread which describes alot of the symptoms I get too. No one seems to have fixed it… bar buying a sc2

That is really frustrating!
I guess you have checked the seating of the encoder on the servo and if there are any error logs in Granite? Mine also had an electric feeling through the wheel when it was playing up which was very strange, It seems to have stopped now but still does it from time to time on startup. I have also done a secondary ground loop from the main box to my rig just in case that was the cause.

This is really strange issue, and might be caused by the encoder. If there is noise in the encoder signal so that it effects the counts as seen in Granity, then (if there are filters running) that same noise might be able to be felt on the wheel. But it is also related to the torque controller settings on the servo drive.Easiest way to adjust those would be to change parameters MR and ML (resistance and inductance).

Hi Mika
thank-you for responding.
yes its a strange one indeed.
Last night I updated re applied IONI firmware version 10716 and the drc for my wheel from within granity tool with no change.
I have a mate overseas that has the small mige version and asked him to tell me if he feels any harmonic vibration when on the bump stops , he does not. he also said his desktop spring does not work.I believe he is on Simucube_fw_1.0.24.
Just sitting at my desktop ,With no desktop spring on and moving the wheel slowly I can feel this harmonic vibration and noise and it feels worse going past the 120 degrees on wards. I can replicate this at a much more intensely at the bumpstops (soft bumpstop) with desktop spring on its even more pronounced,.Ive described what has happened ingame and on desktop in first post.
It seems to have manifested itself after one of the firmware updates , possibly something may have glitched during the update?, Im currently on the latest Simucube_fw_1.0.25.
Is it possible to go back to a clean version of simucube without reverting back to mmos and what would be the process if so.

Firmware binary integrity is checked on each restart of the system by the simucube bootloader. It is simply not possible to have “a bad flash” - in that case, the firmware would just not start at all.

1.0.24 is an unsupported old version. It did have a bug of centering spring not working.

Hi mika

Would or could this cause the simucube to do the restarts after I feel the harmonic noise and friction while driving, happened a few degrees off centre left and right.
How often do BISS-C encoders fail.?.
I just trying as much as possible to understand a way to fix the issue. I never see any fault codes.
I’ve gone and loaded up a different DRC file and will test again.