KartKraft and Simucube

simucube

#1

We can maybe start a thread regarding this sim…


#2

No more input lag…


#3

Strange that any sim these days would have actual input lag. Is there a particular setting that affects this in KartKraft?


#4

@Mika,

this was at the first “start” of the game. And it was with
-Reconstruction filter to 1
-And the torque bandwidh limit to “unlimited”

Today i put the bandwidth to unlimited and testing between 1 and 5 on the “reconstruction filter”


#5

Is it significantly better than the karting DLC in RF2? (If you have tried both). I found it quite fun but not sure if I need more karts in my life as I don’t find myself using that dlc all that often…


#6




I’m pretty happy with this right now. It’s pretty much nullified osculations for me.


#7

Add some FFB FILTERING (4 / 7) and feel the difference …

And don´t forget at the beginning of the steering wheel setting configuration to choose a wheel in the list (i´ve chosen the t500)


#8

After the patch yesterday I now have some major oscillations, like quite severe actually. It was fine before the patch.


#9

Hi,

KartKrafts physics run at 500 Hz.
After the latest update they added a skip FFB step option, with 5 steps maximum, for controllers that can’t handle the speed.
With the simucube we have to use setting 3 where setting 0 is the optimal, 3 corresponds with about 120 Hz.
Is this due to directX, Or other causes?, can this somehow be optimized?


#10

I noticed that I even had to go to setting 4 to get rid of spiking in the FFB.
What I don’t really understand, it’s not logical.
With e.g. Iracing we were suffering of a low Hz output of the sim causing spikes.
This sim outputs 500Hz, and it can’t be utilized without the physics of the sim collapsing at that frequency.
Can someone please explain what could be wrong here?
Thanks in advance.


#11

This might have something to do with the way the simulator is running its internal physics engine. Naturally more higher update frequency would reveal more spikes from the physics.


#12

That could be the case,
But why can other wheel systems run at setting 0, or 500Hz, without causing the sim (physics) itself to collapse.
The FPS go down severely (1 FPS) and the karts fall through the track when running it at that setting using Simucube.
Thats what makes it illogical for me.
I asume there was no contact between you and the dev of Kartkraft?


#13

I haven’t had any contact. There should not be any FPS issues either, so maybe they are doing something strange with the FFB code and as we are relying on the Microsoft driver, there might be issue with that and it would work on some other device.

Maybe I’ll just get myself kartkraft and get some ffb debug…


#14

It’s great fun driving it btw, and still early access.
So possible there are some things that need to be changed.
Great and nice community on discord also.


#15

Debugging this has progressed, and I’m working with the developer to fix the issue.


#16

Has this issue progressed recently, or if not, does KartKraft still work relatively well with the aforementioned filtering settings? Thinking about picking it up now that it has VR support.


#17

Yes, we found that they were creating and starting effects at 500 Hz rate, with both torque and damping being created at that rate. They reduced the extra ffb calls, but it is still not as good as we hope with the 500 Hz rate. It might be that their game engine is blocked during the FFB update calls OR that the default Microsoft DirectInput (HID) driver has not good enough performance.

It still very playable with the skip steps 1 (250 Hz) or 2 (125 Hz) rate.


#18

Thanks @Mika!

Is the part of the SimuCUBE code that deals with reconstruction filter open source? Have been increasingly interested in how a lot of this actually works (especially what the “complex algorithm” used to reconstruct is). I looked around the GitHub repo but didn’t find it, but maybe I’m looking for the wrong thing and/or in the wrong place.


#19

The Reconstruction Filter is done in IONI drive, and thus it is closed source.