Issues with FFB not being present when getting in the car in iRacing

Periodically when I jump in a car in iRacing there is no FFB active. Following suggestions I’ve seen here and in the iRacing forums I can sometimes get it to work by turning the wheel off/on helps engage it, or unchecking the “enable force feedback” box in iRacing will engage it, or sometimes alt-tabbing to TD and changing profiles from one to another but none of these are a foolproof reliable way to fix it when it occurs.

If one of these worked all the time I’d be okay with that…but after the Daytona 24h this weekend when the problem reared it’s head, I’m hoping someone here has some suggestions. I was getting ready to jump in and do my mid-morning stints but FFB would not engage reliably. While in the car, and after service had been done, none of the items above resolved the issue. I drove around 1 lap then pitted again and handed it over to my teammate and so I spotted for the last 5 hours because I couldn’t trust it.

This problem occurrs on both my older machine and the newer rig which I built about 4 weeks ago.

I’m at my wits end. Does anyone have any way to chase down why this may be happening or some suggestions as to what may be causing it or perhaps some common things which I can check? I’m really flying blind as to when it happens and it seems just marginally north of luck that i can get it to work when I need to .

I noticed there is the ability to log events within TrueDrive? Would that help narrow down what’s going on at all?


The firmware logs some events in the internal state machine that runs on the device, and it is mainly useful in finding bugs or other issues. However, FFB effects cannot be really seen in that log, its not something that is being logged inside the device.

Things that can disable FFB:

  • Wheel goes into standby mode with associated long beep, as explained in the user manual. Can be overcome with cycling the e-stop button, or by enabling the automatic High Torque Mode without Standby Mode -functionality via the High Torque dialog.
  • iRacing is started and SteamVR is enabled, FFB effect creation commands are blocked by USB bus when SteamVR is starting, thus there will be no FFB in-game. Can be overcome by toggling the FFB checkbox while in-game.
  • Windows turns USB device OFF. Can be overcome by disabling USB Selective Suspend setting in Windows Power profile advanced options.

Hi Mika - thanks for the response. This is great for me to get started. Thanks for clarifying the log for me.

Maybe it is standby mode but I’m not hearing the beep. I’ll pay closer attention and in the coming days will look at the standby mode function to see if I have it set to automatic. At the very least, perhaps cycling the e-stop button will help along the way.

Toggling the FFB checkbox in iRacing hasn’t been reliable fix for me. Maybe I should leave the wheel off until I’m loaded in VR and then power it on? Not sure the order in which I turn things on matters.
However, perhaps there are other factors at play that prevent the FFB toggle from not working (like perhaps I’m not noticing that standby mode has been entered). I’ll pay closer attention in the coming days to see if I can pin that down better.

I’ll double check the USB suspend setting as well.

In that regard, is it preferable for the SC2 to be plugged into it’s own USB card or rail? So it isn’t using the same set of USB plugs as say my keyboard or wheel? I do that for my VR headset but should I be
doing that also for the SC2?

Thanks again.

hello I have the same problem for 2 days also no ffb when I get into the car or steering angle totally different from that of the loaded profile, a possible solution?

What firmware version are you using? So far for me 2021.7 has been perfectly stable, the motor even runs cooler compared to some of the previous version I tried

I have the latest version 2021.12 the problem since I switched to the last version can we go back to an earlier version?

Yes it’s possible just follow these steps

1 Like

Mika - I can confirm I have high torque mode enabled within the original dialogue and can confirm that toggling the FFB option in game is not effective. Also I can confirm that on this machine that USB suspect has bee disabled.

In the coming days I will try again and use the e-stop to cycle standby mode, if it is in fact going into standby.

2021.12 as well. Did you have the same issues I described above with difference firmware versions?

Latest stable is 2021.9, but it has that pesky warning about Classic being discontinued (can be suppressed for 30 days though)

Andrew - when you say “latest stable” am I to take it that the 2012.12 firmware could be the source of my issues? It seems stable other that.

Anything after 2021.9 was plagued with issues, wireless wheels not being recognized is the most common, I believe it was the point of FW rewrite, Mika can explain better.
But yeah, two good releases in the last two years 2020.10 and 2021.9.

1 Like

No I did not have that same issue, 2021.7 has been perfectly fine for me and I see no reason to update. 2021.7 doesn’t have that “friendly” reminder either

That is gross exaggeration of the actual issues that have been in those releases. Don’t spread the FUD.

12 versions of TD in one year to get what already worked fine with 2020.10 is not a gross exaggeration … and it still doesn’t work


me the problems arrived with this version I never had the slightest concern before.

I confused by the apparent suggestions to go to an earlier firmware version by people who aren’t experiencing the same problem. I mean, I certainly appreciate the comments but what value are you offering to troubleshoot the issue by suggesting changing firmware is a the solution to a problem you haven’t had?

Stop hijacking my thread. I’m looking for genuine guidance instead of half-measured ideas. To whit; Mika is the only one who offered some thoughts.

Start your own thread griping about it…

1 Like

Thanks for the comments :slight_smile:

If there was any FFB related firmware issue in the latest releases, we would have much more reports about it by now.

Because other people have had similar issues after updating to a more recent firmware, we’re only trying to help and to provide a solution. A firmware downgrade only takes a few steps, trying it is a solution to your problem

Everyone is trying to help everyone