Irratic and dangerous force feedback freezes/movements in iRacing and Simucube 2 Ultimate

Hi Community,

recently I run into this actually rather dangerous issue in iRacing and my Simucube 2 Ultimate. It’s happening rather regularly - basically almost every session and it feels like it’s getting worse. I don’t know if it’s an iRacing/Software, or maybe Simucube 2 Hardware issue:

At some point the virtual steering wheel and force feedback get’s stuck at a given point pushing/pulling into one direction sometimes violently.

  1. this leads to crashing into the wall or others immediatedly and 2. I did hurt myself several times already, as the feedback following such an incident is crazy strong and unpredictable.

The simulation = graphics are going on just fine, it’s like the telemetry/feedback is having a seizure or not getting any updates for some time. Any idea what is causing that and how to get rid of it?

I have recorded one situation, just after the right hand corner the steering went very strong to the left by itself, I tried to hold in on the track and then it went kind of ballistic from there with irratic movements:

Any idea of how to find out what’s causing that?

best regards,

Has this started just recently? Have you made any changes to your rig?

Yes, but I can’t put a more precise time to it than recently. I was using Simucube 2 Ultimate and the rest of the simulator hard-/software setup for years without any issues like that. So no recent hardware changes I can think of.

It feels like a disturbance / huge lag in the force feedback stream causing the steering ro get stuck in a given movement (generally pulling into a given direction very hard), and then getting irratic after the break. So far I have no idea what’s the possible reason.

  • problem with iRacing’s telemetry/force feedback output
  • connection/lagging issues to the iRacing racing server and/or internet connection issues (but as far as my Internet connection is concerened it’s super fast and rock solid for more than a year now, so I doubt it’s my internet connection$)
  • some hardware issue wheel base, USB connection, CPU,…? interfereing for some time and causing this
  • driver issue - which?

I try to figure out if more iRacers experience this issue and/or if I experience that in other simulations as well.

But just now I did a whole session in iRacing without any issues and I also can’t remember having that in another simulation… So it’s tricky to test…

It is indeed interesting issue and something that I haven’t seen before. The jerky inputs is very interesting.

Can you comment if the wheel center point remains good? And if the FFB itself works OK afterwards?

Yes, everything is working perfectly fine right afterwards. It’s only a matter of about a second or so.
Sometimes I just feel that the feedback is off for a moment and I can continue to drive.
Sometimes the wheel continues to pull very hard into one direction and I can try to fight it.
Sometimes my steering get’s disconnected from what the steering in the simulation does, so there is no force feedback, but the wheel in the simulation goes into a given direction and car ends up in the wall with nothing I can do against it.

All of that feels like the connection of steering wheel and force feedback stream of the simulations gets interrupted.

I do think that I experience this issue more likely

  1. on an US iRacing server (contrast to en Europe based server)
  2. like yesterday after the iracing season update when a lot of users are on the servers

so I suspect it has something to do with the reliability of the connection to the iRacing server and that sometimes there is a too big lag in the force feedback data stream - or however that is working.

Unless there is a Simucube 2 hardware explanation for that.

Well, the simulator and the FFB runs on your local PC, so it really cannot have anything to do with network connectivity.

There have been some USB ground loop / grounding issues on some rigs, but usually they just disconnect the wheel base completely for x amount of time. The video you show is something totally new, and we are analyzing it.

Does the FFB feel smooth when the jittery inputs are happening, or is the FFB also “jerky”?

Do you have vJoy installed and enabled by any chance?
I’ve recently found out that Win11 update for some reason enabled it which was causing some weird FFB behavior.

hm, I don’t know that vJox is, so I guess not…

I do have JoyToKey installed, but I am using this for years by now…
Also I am running Win 10 not 11…

ah ok, I haven’t thought / din’t know that. I thought that there is data coming from the server as well - I mean when I hit another car, this has obviously an effect on the FFB and has to be calculated on the online server, hasn’t it?

Otherwise that’s a tricky question about the quality of the FFB. I just had a small artefact in a quali session now in iRacing. The FFB was pulling to the left (on a straight for no obvious reasons) for a very short amount of time.

It’s coming in different “flavours”…
When it’s getting stuck pulling in one direction, that’s smooth, or a fixed pulling force. Sometimes it’s suddenly very violently, like oscillating.
In the video to was pulling to the left initially - smoothly. After I tried counter steering/holding and the FFB started to react again it went into a violent oscillating movement… So not sure how to describe that otherwise.

I’ll upload more situation when they happen… I had a big one yesterday, but the stream did not work…

Today the virtual steering got stuck for a moment - so my steering input into the left hand corner was ignored: (I have that on replay only sadly, so no real time levels…)

Next best option is to try on a different PC or reformat your PC and start fresh. This seems like a PC issue to be honest

It makes me sad to read your article, over here Simucube 2 Ultimate, win 11 and iRacing working perfectly.

I have uploaded two more instances recorded with external GoPro camera from the cockpit for real steering wheel input and extra input levels shown as well as steering wheel icon for virtual steering wheel movements captured in the lower left corner. There is actual a short weired spike to be seen in the F bar - not sure if that’s the cause, or if it’s caused by the difference between simulation and real steering wheel position.

I also did sessions in AC and ACC and had no issues whatsoever. I therefore would rule out a USB-cable or wheel base hardware issues.

FYI iRacing forum thread and discussion regarding the same issue, also with no solution yet:

Seems like iRacing recently updated the FFB code, and it’s bugged:-

So, it really doesn’t seem to be a Simucube specific problem, especially in light of comments in your iRacing thread saying that the same or similar issues are occuring on Fanatec equipment as well.

It’s embarrassing, but yes I have revealed that I do indeed have an iRacing subscription. However in my defence I will say that when I purchased it, the subscription was dirt cheap and I was filthy drunk, and that I have never installed iRacing.

Cool so what have you done to try and fix it? Have you tried any of our suggestions? We’ve determined it’s not an SC2 issue as it only happens in iracing so probably best to discuss this on their forums

@ [designamk1]

  1. I do - hence the link to the forum post?!

  2. Well, iRacing staff suggests it’s a problem of the wheel not communicating with the simulation, so that’s that.

It’s easy to suggest just start with a new pc and re-install everything without understanding the consequencies this would cause… That’s approx.a week worth of 24/7 work and interruption of business on top of that…That’s not an option, just because it’s the easiest reply/suggestion for you.

I agree it could be a driver or software problem. could turn out to be the very same problem again after going through re-install when eg. one of the latest updates of said driver or software is causing that. It used to work perfectly fine and I did not change anything on my side other than mandatory updates…

@ Slapped

I’d love to agree, but sadly it’s not that simple.

  1. iRacing staff and myself are quite sure the problem described by the other user are in fact a different issue.
  2. iRacing staff at the moment repeatedly thinks that it’s an issue with the communication between wheel base and simulation saying that the wheel base fails to send the movement updates to the simulation. Or something in between is causing interruption of data flow - like USB cable problem, or driver problem, or CPU time issues…

I am not convinced that that’s the case, but they are investigating it rather carefully by now. Bottom line so far we don’t know exactly what’s happening here.

Also it’s difficult to test as it does not happen too often, so I can’t just change something and test it for half an hour… That makes it much harder to test/eliminate problems.

Have you tried a newer or older firmware? Have you tried a different USB cable or USB slot on your motherboard? What have you tried so we know? You have listed all the issues but you haven’t mentioned what you have done to try and fix it. I know you are reluctant to try any suggestions though based on the previous issue you had so that’s why I went to the extreme and mentioned a reformat

The main problem is that it is very hard to reproduce the issue. So it takes days to find out if a given change might have any effect.

So far I turned off the XMP memory profiles on the motherboard bios (it was not OC, but just running the actual memory specs, but still I heared that XMP can cause problems) and stopped using the active seat belts controlled by an andruino controller because I know that one was super picky with USB cables.

As of now I did not have another instance, but as I said it’s very hard to reproduce it, basically it comes down to using it many hours and see if it eventually happens again.

Again, it’s weired because when I started the discussions I had that problem basically in every session for a couple of days and I did have the feeling it was more related with US-servers, or very busy iracing servers in general… But then MIka said, FF is calculated locally… So… Let’s see…

Don’t worry, I’ll keep trying things. I was hopeing that ther might be a possibility to investigate and find whatever is causing that. A tool identifying USB traffic issues eg. Or CPU bottlenecks

One reason why I consider the CPU load True Drive is causing by showing the steering wheel (up to 6%!) is a problem is related with that too. Because I did notice that even with very modern high performance CPUs sometimes a stupid combination of threats are obviously calculated on the same core. iRacing is known not to facilitate too many CPU cores (basically using only 1 or 2) and if the wrong other tasks are happen to run on the same core, it’s causing problems very fast - despite having 10 other corse getting bored… Therefore I am always cautious of how much CPU performance all those many additional tools and drivers are using…

I worked as a DJ for some time, and you would be surprised how difficult it can be - even on a high end fast computer - to establish reliable audio stream output with 100% no high latencies going on at any given time. Eventually a stupid Wifi-driver, win update or any other stupid tool is kicking in and disrupting audio stream for a few milliseconds… For that there is a great little tool measuring the system latency (dplatency). I found that incredibly helpfull to identify a problem otherwise completely invisible.

I was hopeing for something like that to identify the issue, before going berserk…