IONI Drive Config Files for MiGE 130ST-AM10015 (medium MiGE)

I have recently purchased a medium MiGE motor 130ST-AM10015 and I’m looking for the IONI drc setup file online without much luck. Does anyone have this motor and are using a SIMUCUBE/IONI controller? Can I just use the setup file for the small MiGE and work from there? If so, which settings should I focus on? Thanks in advance.

1 Like

I’m using the BL70-300 happily if that’s of any use. I’m guessing it’s just a case of adjusting the pole pairs (if necessary), the encoder counts, the current settings and the gains.

Once you’ve got the wiring right, it generally all falls into place - until then, it’s tricky.

If you email me at I’ll help where I can. I have successfully used about 40 IONI drives with various motors (but I don;'t think yours specifically) so happy to share/help.

1 Like

You can probably start with the a small mige drc (10010) like the ones that I have in the iRacing forums. Choose the correct Encoder type and PSU. if using an SDR or you don’t know the wattage you can use the unlimited version.

Two things that will NEED to be changed in Granity are MMC would need to be increased to 21.17A to get Maximum output and it would be a good idea to click on the Measure Resistance and Inductance button to set those numbers to your servo.

1 Like

I have last week provided the OP feedback on all the changes required in another thread here -->> New OSW build - MiGe motor(s) consideration (speed, inertia)

1 Like

Hi Beano,

Well I finally managed to get this system assembled and installed the Simucube firmware (with a lot of cursing). The initial install also automatically updated the firmware in the IONI board and thats where the story went a different direction. I uploaded a small mige DRC file and made the changes you suggested but immediately got an error due to too high current so I changed this to 14A as you suggested. Now, when I open the E-Stop I get a bunch of errors from the drive which have me stumped!

I have uploaded some screen shots if this helps to understand my problem.

I’ve also attached a txt file with the info saved from the Granity testing tab. Debug.txt (2.5 KB)

Many thanks in advance for any help that you can provide.

Your error indicates that the e-stop is pressed.

1 Like

Thank you for your quick reply Mika. I also had the motor earth connected to Pin 4 of the X1 so when I resolved this it worked! Now to get racing!

Solved! I had the motor earth connector in Pin 4 of the X1 DOH! Was able to use Granity to get the resistance and Inductance figures and then configure Simucube. Works like a charm now!