Fault location 480901

Hi to all. Am getting a fault location 480901 sometimes on SC2 PRO…When PC Is turned on .then turn on the SC2 then start TD sometimes this fault appears i press the estop and fault clears …If i start TD first then SC2 i never get this fault ?..also both blue lights on the psu are on before i start TD or SC2…

We have seen this as well and are looking into it.

1 Like

Hi Mika. just loaded the new 1.08 , and got the same fault again 480901…cleared with the e stop then tried again 4 or 5 times and no problem ??? regards denis

Our first try to remedy the issue is in 1.0.8 and it seems it was not correct. We are still looking into this.

1 Like

Same here, during a iRacing practice session error showed.
Enabling E-Stop and Disabling E-Stop solved the issue.
Hope it doesn’t happen in a race …

so this happened while driving, and you were not making adjustments while it happened?

During adjustment when I had iRacing open.
I thought it was my active session… (assumptions… :expressionless:)

Ok, it would be a clear hint towards a solution! Thanks.

I occasionally see this fault code too.

It only seems to happen for me if I have the servo powered on before starting the PC, like this:

Power on Servo
Power on PC
Open TD (fault code appears)
Press/release e-stop (code dissapears)

I have never seen the fault code if I follow my normal procedure:

Power on PC
Power on Servo
Open TD (no fault code)

With me it happend on turned on pc and sc2, then i started steamvr, think index powered on and this code appeared in TD. Also removed with e-stop on/off

Issue happened again yesterday while adjusting settings in iRacing.

On Monday we had an AC race where I adjusted a lot in TrueDrive to get the correct feeling, no problem.
In both cases I had the same programs running for VR, CF, rumble etc etc
Press and release e-stop fixed the issue.

Not a big issue, reporting it for the devs

Did you test with latest vers 1.09 fw?

My unit is on True Drive version 1.0.8 and FW 1.0.8
There is a remark : Correct firmware is installed.
When clicking on “Click here for updates” it takes me to the website where the same version is shown.

Where can I get 1.0.9? (Simucube 2 Pro)

Contact Mika Takala for beta 1.09. He will sent to you…

1 Like

Hi Mika new TD installed 1.0.10 and so far no fault code . I try 10 times and all good …regards Denis

1 Like

Using TD v1.0.10. SC2 USB plugged into motherboard-direct USB input.

The first 2 or 3 days I used my new SC2 Pro, I didn’t get this fault, today I got it. All I did was restart the SC2 and TD and the fault was gone.

To Granity: Is it better to shutdown the motor first (power switch rear of motor) or TD software? What about when turning them on? My PC is always first to power on and load windows & always last to power off or sleep; I’m just wondering about the SC2 hardware VS TD software order…

That fault is under investigation, and is already happening more infrequently than before on the latest firmware version. We do have an idea where it happens, but we need to catch it happening on our test device with a test firmware to be sure on what is the next step to fix.

The error is happening completely internal to the device. Order of shutting down / starting up does not matter.

1 Like

Hi I got my SC2 today from Augury. Please help I have no ffb. High torque is enabled and I had ffb the first two runs. Don’t no if I have saved or did something wrong in TD I have ran other set profiles and no ffb. My e stop is disengaged.

I had the above error show once but it has disappeared


I know this may be obvious but I’ll write it just in case. Power off the SC2. Shut down True Drive (TD). Power on SC2. Wait for SC2 to finish power-on beeps. Open True Drive. Enable high torque mode (press the enable button, slide the bar, click the activate button). Go to the game settings in True Drive (icon on left with 3 orange cars inside orange hexagon). Profile will probably say “Read-only safe profile.” Click on that and select another profile in the list you made. If you don’t have any profiles listed under the “Read-only safe profile,” click the “Add” button on the right to create a new profile. Make sure you save the new profile (save button on bottom). You’ll then see the newly created profile in the list and can select it whenever you start TD.

Followed each of those steps and no luck.