F1 2018 Thoughts and settings


#1

Whats up guys? Just installed F1 2018 and it is better for sure, however quiet a bit of vibration from the wheel like motor noise which if there is anything I can do let me know please. Share your settings if you do not mind of course. Currently running 90 ffb in simucube and 70 in game. Have not tested anything else. Also when loading the game up on triple montior its flashes like 5 times randomly on the screens before loading up the game. Thats probably a different issue.


#2

From what I could feel, it was quite OK with slight road vibration, but then again I don’t run that high FFB levels myself, and neither do the F1 cars have high FFB in real life as they have power steering.

Good thing that we managed to get SimuCUBE detected properly in F1 2018.


#3

my game doesnt detect the wheel, inputs dont get recognized too

now i got it to detect it. dont know what the issues was


#4

Would you mind sharing your settings I would be interest in testing it out. Everyone is saying to drop road texture down for the straight line vibration.


#5

I did not have the time to spend to try to adjust any settings from default.


#6

I’ve the same issue. I found only Keyboard, nothing else.
How you resolve this?


#7

dont really know, just restarted the game 2-3 times and then i could map left and right


#8

I think the game has a USB input limit. I had to unplug some of my extraneous gear to get my SimuCube to stick.


#9

Tested this game yesterday and i think it was a lot better than i think it gonna be.
For wheel detection just rotate wheel all way to needed direction and roll it back.
Worked for me.


#10

Yep must turn wheel all the way to left then back to centre for axis to be picked up .same with button allocation they wont show up till pushed and released .


#11

sorry to bring this one back from the dead but does anyone have decent settings for a small midge? Just got a Augury F1s rim and surprisingly f12018 detects everything :smiley: