Converting from Wireless to Wired With Bump Stop


We had our wheels converted to wireless due to wheels over spinning and ripping the cables,

But we have had a lot of problems with low battery, disconnecting in race and many more,

Our experience has been bad,

We would like to go back to wired - to prevent wires being torn apart we have the idea of adding a bolt / plate on the top of the Hub of the wheel with a bolt 180 degreese to the bottom with some padding.

This would physically limit the wheel turning more than 180 in both directions, after a lot of driving in 99% of driving circuit and formula races we never need the wheel to go past 180 degrees in both directions total wheel range 360 degrees.

  1. How can we step by step modify wireless wheels to go back to wired with the wheel button control back and flappy paddles

  2. Has anyone else / How can we add physical bump stops to prevent wheel rotating more then 360 ripping wire out

Our end solution will be a working wheel hard wired and not be able to spin more than 360 to rip wire out, eliminating error.

I have linked a screen shot of the error nearly all sims get after during playing


Which Simucube firmware version is this? I thought we have disabled the torque disabling on wireless wheel disconnect some time ago also for Simucube 1 - it is definitively like that in latest Simucube 2 firmware release.

Also, can you say what kind of wireless wheels do you have? DIY or commercially made? Do they have external or internal antennas? How about the receiver on the Simucube 1 - is it within a metallic enclosure?

I just checked the source code for Simucube 1. The torque will be disabled on wireless wheel disconnect, only if that wireless wheel had a special torque on/off switch configured in the wireless wheel module. There is no such button configured by default, but this feature is available for added safety for those that need it.

For Simucube 2, this was changed to be like this in release 2020.4, and all Simucube 1 firmware releases since the Summer 2020 have been like this.

Hi Mika,

Thanks for the response, I have attached screenshot for you,

From the sounds of it, if we have the correct firmware would this be something we could disable? which will then stop the wheels failing mid-race?

Our wheels DIY From a partner here in the UK but have had issues with dealing with problems with them so we are trying to fix them ourselves

Also there using x2 aaa batteries for total 3.0v - for increased life is there a way we can replace and upgrade to to maybe 9v smoke alarm battery to help,

they wheels seem to be all enclosed with the simucube board exposed under a wooden table I will send some attachments

  • Your firmware version is two and a half years old, see:

  • Absolute maximum battery voltage is 3.8 V on the wireless wheels. Any higher than that risks physical damage to the module on the wheel. 9 volts would burn it right away.

  • Can you check how tightly the batteries are in the battery holders? It is well possible that they shake just a bit too much which causes interruptions in power.

Yes, that feature is disabled in the the latest Simucube 1 firmware releases. I’m just now checking which version was the first one with the same change that we did for Simucube 2 in release 2020.4.

I found the commit. This change (no torque disable when wireless wheel disconnects) was made in July 2020 for release in 1.0.24 / 1.0.24 version.

Also, bumpstops have been completely reworked. They had bugs in the old firmwares, making it possible for wheels to rotate over bumpstops, as game generated forces were able to overcome bumpstop forces. This has been completely rewritten and improved in all releases since your 0.50.4 release, and our last Simucube 1 release also fixed a bug caused by RaceRoom that managed to overcome all code protections for the fix…

Great!, I can see In July there is

July 31st 2020 - Battery consumption
1.0.25 / 10716

July 25th 2020
1.0.24 / 10716

I have attached a screenshot of our PC

Just for clarification. should we upgrade all our units to 1.0.24 Version or is there a better newer version we should upgrade to as we are still on the old units.

Also with the bump-stops mentioned below, will this be resolved with the upgrading of this firmware


You should update to the very latest firmware.

Regarding Battery, yes the holders are a little loose with not the strongest springs holding them in,

Would you recommend a rechargeable solution such as something like

or any other recommendations other people have done. we would like to be able to have them running for other a month of use before needing to be recharged

Well, we’ve have had a double AA battery based wireless wheel module constantly ON in our office since 2018 and it still hasn’t run out of battery. Rechargeable is way to go only if absolutely necessary.

I would put some tissue paper or similar to make the battery holder hold the springs more tightly against the battery. That would rule out the contact being the actual culprit of your issue.

I think our issue was to do with firmware, I will be replacing the batteries and securing them well in there housing.

I will see how it goes for a week with these changes made, we haven’t had a single day without issues but after the clarification you gave, I think we can go a week with no bugs / issues, I will update on status also.

While I am here I would like to ask the question with sticky button, On our wheel we have a button when pressed wont push out, do you guys have solution to help with this? or would we need to re solder a new switch or can we clean it with something?


I would try to replace the button somehow, but I’m not familiar with that button box - is it the one that Simtech Racing sells? Perhaps they have spare buttons? Replacing is likely to require soldering skills. And, just by looking at that picture, it is impossible to say what make&model buttons those are, but they are very close to some ebay/chinese generic no-brand buttons.


So we tried updating on one machine, the main one that had the regular failure.

I downloaded the latest Simucube download as mentioned before

But when I downloaded and clicked on the run application I kept on getting the following error,

Would I be able to get any help or guidance / steps on how to install update firmware correctly or if iv done something wrong


Are you trying to run it within the zip file without unzipping? That will not work.

I did extract all to desktop and still same issue

ah, now I see the error. You need to install the latest Microsoft Visual Studio Runtime package. Link is on the firmware download page.

Your recommendations have all been successful, and what to thank you for your time on helping with our problems.

One recent issue we have, on one of our sims with the new updated firmware, we are trying to connect the wheel on Simucube But when we select and connect, it does not show connected and playing in game there’s no response,

I have attached a screen shot, the top one I believe is the issue wheel, with the other names from other wheels,

It has worked before so not sure, is there a way to investigate that this wheel is broadcasting and why it won’t connect.


Wheel will only advertise for 30 seconds at power-on, so it might be added to the list but you are too late on double clicking it, so it will not connect.

Or, the wheel manages to connect to another previously paired Simucube unit, but the momentary scan result stays on the list.