Wireless wheel not detected

Hello guys!

I’ve not been using my rig for about 3 months. Today I decided to go and do an AI race in iRacing and so I started to update everything and give it a go. However my Ascher wireless wheel is not detected anymore. I dunno if it was due to updating True drive (from 2020.3 to 2020.7) or is it something with the wheel. The wheel is blinking with green light, which from what I know it means it is in discovery mode. But it is not displayed under the available devices. I’ve also tried to manually get the wheel into discovery mode by holding the shifters for 5+ s, but still no effect. Does anyone have any idea what else I could try? All the help is greatly appreciated!

Does the wireless wheel keep doing the flashing for a very long time? That would mean that it’s battery is depleted. How was it stored?

Also, you should be able to see the wheel as some SC2- -named device in Bluetooth devices with e.g. your phone. You could rule out issue with the wheel or Simucube 2 by checking this.

Yes it never stops blinking with the green light. The wheel was powered off and left on the rig (I think, since I always turned the wheel off when I turned off SC2 and stopped using the rig). I can definitely try replacing the battery. I’ve also checked with the phone and there is no device that has Ascher or SC2 in the name.

Thanks for the help, I will report back once I replace the battery. Hopefully I can get them in my local super market :slight_smile:

If supermarket is not a match, then your local camera/photography shop is likely to have them as well.

Never seen these type of batteries. What kind are they? Not really sure what I am looking at :slight_smile:

Its a 3.6 Lithium battery, but I’m not at home and thus can’t find out the exact model. Is it printed on battery or on Ascher’s website?

Found it on the Ascher page. 14250 lithium 3.6 V battery. Thanks for the help for now! Hopefully its just the battery :slight_smile: Also props for such amazing speed on replies!

1 Like

It was the battery. It connected immediately with a new battery. Not sure what went wrong, since I am pretty sure I didn’t leave the wheel on, since I never do. Hopefully its not a HW problem, cause the battery was supposed to last 2-3 years of heavy daily use, not 8 months like mine did.

Anyhow, thanks for the help Mika!