Wheel not working after update to new beta ioni firmware

I have the small mige with simcube and ion HC Pro with 480/720 W power supply with sincos 1.2m encoder.

Upated to beta 1.6.30 fw and experienced low level of noise from motor which was great.
Iwasnt too sure about the forceedback improvements so reverted to the earlier 1.6.0v fw which worked and back
to new fw to check. However on the last occasion the wheel stopped working. I get a pulsing orange light showing ontop
of the simcube box. When i turn to box on the wheel dont move right and left and feels dead. I cant find a way to flash the firmare through granity.
I have tried simcube enable via usb to reach granity, however when connected it shows no simple motion drive found.

Try hitting the emergency/kill switch so the servo itself is switched off. then try to install FW again in Granity. after that restart Simucube with emergency switch released again.
Hope this works.

Thanks Eddy, tried the kill switch method before installing FW in Granity, unfortunately I still can’t connect to Granity because it does not come up with any list of power drives found in the Simplemotion bus, I wonder what this means.
I have checked Device Manager on PC to check for the Simplemotion V2 Adapter on USB Serial Port Com7 but does not say Simplemotion V2 Adapter in the device manager as it does on Granity I dont know whether this is working, thanks all the same

Interesting; the IONI firmware should appear in bootloader mode even after failed firmware flashing - and that should not fail.

If you can, you can put the SimuCUBE into DFU mode using the dip switch method to see if IONI is visible then in Granity.

Hi Mika, thanks for your input, I have tried setting the switch in the Simcube box itself to place it into DFU mode position and thus uploaded the bootloader again using application Dfues demo successfully, and placed the simcube box back into run mode, however unfortunately after trying this process still cant connect to Granity, as Granity states no list of found and powered drives in the Simplemotion bus when I connect to drive.

Before this, with the PC switched off, the midge use to turn the wheel right to left when I powered the SimCube on, but now there is a flashing orange light even when the Estop has been disengaged, strange… I am aware that I have to try to reload the FW into Granity but mother(Granity) will not let me speak to her:slight_smile:


I meant that by leaving the SimuCUBE into DFU mode, it should always be possible to connect to IONI via Granity. You don’t need to flash SimuCUBE again, just move the dip switch back.

Does the IONI blink match any of these sequences?

Excellent! Just leave it to the professionals I will say. Mika thank ever so much . You are genius, just left DFU Mode running with the dip switch as you said and was promptly accepted by Granity.
I must previously not followed to the whole procedure when changing FW and shorted the system somewhere I imagine and therefore cut out.
Good things is all my other settings were also kept intact.

wonderful!! So so happy, Santa has arrived early for me too :):smiley:

Big respect, you made a big problem look like small potatoes in a few words! Best!!