Wheel is too near or over endstop

I need some help. I bought my SC1 with small mige and ioni sin/cos encoder 2nd hand. When I first set it up it worked as I believed it should for a while. Now I am having problems.
When I turn on the simucube, right after it beeps the wheel spins pretty fast a few times, then stops. I have to disconnect the USB to my rim to make sure it doesn’t get ripped out. Then when I open the Simucube Config tool I get a safety warning. It says, “Wheel is too near or over endstop. Simucube has disabled force generation. Force Generation will resume when you have rotated the wheel back to near center. This dialog will close automatically.”

However, when I rotate the wheel nothing happens. I can go bumpstop to bumpstop and the warning doesn’t go away. If I close the warning, the wheel will work fine, but sometimes I’ll lose FFB out of nowhere, and have to restart the simucube to get it back.

I’d really appreciate some help in getting my wheel working properly. Even if I have to reset everything back to factory default, that’s fine. I’m not really concerned about losing profiles or anything. I just want it to work as it should. Thanks.


When you power on the system, hold the wheel and press the e-stop right away. Then try to reset wheel center at that position.

If the software does not allow to do that, then redo the motor configuration wizard without supplying any drc files.

Ok. I held the wheel and hit the e-stop. Then I reset the wheel center. Then I released the e-stop. Still got the error though. Then, I shut it down and restarted it. It didn’t spin this time, but I got the error again.

Next, I tried redoing the motor config wizard. I removed the DRC files from the simucube folder, and then ran the wizard. I attempted to initialize and then I got this error: “Motor did not initialize in 30 seconds. Probable cause for this: Wrong settings for the motor.”

Now what?

Bump. Still hoping someone can help me with this. I’m still getting the endstop error.

Possibility 1: Probably something has gone wrong at the Simucube firmware, corrupt settings or something. I think what is required is to install the firmware again - there is already the Simucube-firmware-and-reset-all-settings.dfu file available, but it must be installed with DfuSeDemo and dip switches.

Possibility 2: Can you test if the motor initializes in Granity?