Using 34 bit Biss-C sensor with SimuCUBE

while trying to configure my IONI drive with Granity, I noticed that the sum of single-turn and multi-turn bits is limited to 32 bits. The feedback device I am using is a RoboDrive RD85-AKSIM with Biss-C interface which has 18 bit single-turn resolution and 16 bit multi-turn resolution. When I put 18 bits for single-turn and 14 bits for multi-turn resolution in Granity and then test the settings as described here:
at “Testing settings”, the motor holds position and has “bumps” if forced to turn. I tried inverting FBI and the value for MPC is definitely correct. So I assume that the missing 2 bits of multi-turn resolution could be the problem? Is there any way to make this encoder work properly?
Kind regards

Similar things was discussed here:

Maybe @Tero can help on how to configure this encoder.

Multiturn data is transmitted first from BiSS encoder so it’s not possible to avoid reading all bits of it. So you may try to set MT=16 and ST=16 bits as workaround. Let us know if that works!

Setting MT=16 and ST=16 didn’t work either. However, I now made it work setting ST=21 and MT=11. I noticed that turning the wheel 90° made the virtual wheel in SimuCUBE configuration tool turn 720°, so there was kind of a transmission ratio of 8, although I am not using a gear. Adding 3 bits (=8) to ST did the trick.