Unable to connect to SimuCube in Granity


#1

Hey All,

I bought a second hand OSW Set up (for $750!!) and I’m trying to get it working with my Win 10 machine.

Specs:
---- MiGE 130ST-M10010 servo motor (small MiGE) with 5000ppr encoder
---- 480W/720W SimuCUBE with 480 Watt Power Supply
---- SimuCUBE
---- IONI Pro HC Servo and Stepper Drive

According to the Seller it has Simucube FW Open Beta 0.11.2, but Granity doesn’t connect or even see the SimuCube.

When I go into Device Manager, I do not see it under USB Devices, but there is a HID devices that shows as “USB Input Device.” I am able to verify it by disconnecting and reconnecting, and when I do that the device disappears and reappears. When I click through it shows that the device drivers are loaded and it is working properly.

How do I get this to connect? I tried to manually force DFU mode to reinstall the firmware by using the switch, but still nothing.

Help?

The Simu


#2

You have both USB cables connected at the back?

Can you uninstall that hid input device and delete the driver too, rescan for hardware changes?


#3

Was this up and running for the person you bought it from?
You only flip the switch to install the MMOS, simucube firmware.
You should go to the Granite devices wiki and download the instructions for setting up a new Simucube.
If I was on a PC now I would give you the link.
If you are in the USA you can send me your phone number via PM and I will try to get you squared away. :slight_smile:


#4

@Joe: I’ve got your email, will look and reply back :slight_smile:

Sorry for off-topic, OP!


#5

Granity connection mode must be enabled from the Simucube Configuration Tool. However, there should be absolutely no reason to connect to IONI drive via Granity unless you are going to make hardware changes.

Download Simucube firmware 0.11.2 and just use it.


#6

Thanks to all. I’m embarrassed to say that I had to switch to force the SimuCube into DFU mode flipped the wrong way. I just looked at the diagram and didn’t see it right initially. Nothing to see here…

And yes it’s working just fine now and is amazing compared to my G27. I don’t know if it’ll make me faster, but definitely more consistent and safer. It’s amazing!


#7

I am sure you’re not the first, nor will you be the last, to have done this :slight_smile:

Enjoy your new wheel!


#8

Nope not the first!
He still has not experienced my wheel is not working and I can not figure it out. It was the estop pushed in Dooh! :slight_smile:


#9

Haha, yes, another one we have all done at some point, Joe :slight_smile:


#10

Better pedals with loadcell can also help with that. Also at some point you could change the encoder to biss .