Try to compile and flash SimuCUBE Firmware

Hi everyone,
I’m using Atollic TrueSTUDIO for STM32 to compile the SimuCUBE Firmware.
To flash the firmware, I use the SimuCUBE Configuration Tool software.
The compilation therefore creates a .bootloadable which I place in the SimuCUBE Configuration Tool software folder.
After flashing the firmware, I end up with the following error:

However, I tried to change the version in main.cpp :slight_smile:

But I have the same error.

Do you have a solution ?

Thanks a lot,

You are trying to flash with 0.50.4 version, and it will not allow to do anything if the running firmware version is not the one supplied with it. Also 0.50.4 has some API changes compared to the open source repository code, so it is utterly incompatible with it.

Try to use 0.10.4 version and make your new firmware as 0.10.5 or something like that.

Thanks Mika,
If I understand correctly, the open source version corresponds to the 0.10.4 version ?


Just wondering, what are you developing at the moment? :slight_smile: