TrueDrive Firmware - Update Failed?

Hello all,

please can anyone help with the below issue?

Brand new simucube sport

when first loading true drive, it prompts a firmware update, which upon download/verification it states;

‘‘firmware update failed: device returned wrong checksum from received data’’

I have double checked all cables, rebooted the device and pc multiple times and also installed/re installed various versions of true drive all producing the same error

Any help greatly appreciated

1 Like

This is really interesting. We’ve never seen anyone report this during the lifetime of the Simucube products, including Simucube 1.

Do you have other software such as HidGuardian installed?

Hello - I do not have that installed

I’ve tried just about every troubleshooting idea I can think of besides a different PC

Is this a port on the motherboard that is either Intel or AMD, or could it be an AsMedia chipset on that port? Which motherboard and which port are you using?

Little unsure what you mean there? Everything is just plugged into the PC via USB

it’s an AMD Ryzen 9 7900X and a Asus ROG 670E Crosshair motherboard running windows 11

Which versions of True Drive have you tried to install?


all with a reboot of the system and wheelbase between installs

I’m almost willing to say that its got something to do with the PC and/or Windows this time. Such as overly aggressive antivirus solution or something.

Can you tell us the serial number of the unit?

I shall try get hold of a laptop/different PC to troubleshoot with

SN: 00019162

I’ve successfully updated the firmware using a different pc/laptop - re plugged everything back into my PC again and all appears to be up and running!

I’d be very interested to see what caused this so if you need any information from me, let me know!


Just AMD/USB things again. Especially so on the previous Gen Ryzens, we had huge battles with AMD x570 and USB. I actually replaced my X570 /5900X with a 12900KS Intel setup, the AMD box is now serving as my Fusion dev box.

USB issues were very bad on that one, I was hoping AMD would have fixed that by now.

I’d been experiencing issues with corsairs icue software and the thunderbolt drivers conflicting each other so I’m not surprised to hear it’s likely the cause for another issue!

If your battles continue, we might recommend you to use either an external quality hub, or even an internal PCIe card. I tested both and they worked really well on my AMD setup, but I decided to use Intel for my iRacing rig instead, as the hoard I am using have dual Thunderbolt 4 slots, it works well with my TB4 dock.

All hassles wrt usb devices gone, so happy days.