Trouble with Cube controls CSX 2

Hello Everyone,

I received an Ultimate 2 yesterday and installed in Rig. I find that I cannot run the management software UGT manager for the Cube Controls CSX 2 wheel when I turn on the wheel. The program crashes and I loose communication to the the CSX 2. The UGT software will run if I do not turn on the wheel and it did run without a problem using my previous wheel (Augury/Small Midge). I have tried different combinations of USB ports but no luck. I am not able to drive at all. I did open a support ticket but thought somebody may have come across this. Thanks. (Frustrated).

Just curious does the wheel or the display more to the point operate properly if you don’t run the software as I thought?? The UGT software was purely to program what you see on your in wheel display?, and it didn’t need to be running whilst say playing iracing or ACC?. I know you how the wheel plugged into a USB port on your PC then this particular wheel if I am correct has to have a 5v power source running to it correct so it has to be plugged into a plug as in a mains power source

Hi Jason,

The UGT software has to run to show the display and operate the functions on the wheel, gear shift etc. You are correct it does have a separate power supply from wall socket in conjunction with the USB on the one cable. I currently have it on a power strip.

That is really weird considering the wheel itself is not connected to the SC2 at all in anyway!, this I must admit has me confused!

I think I may have found the issue. After separating the cables between the wheel and my new simucube to avoid any interference the issue still remained. It is of an intermittent nature in that it would work and the freeze with no apparent pattern. I even tested with the whole simucube system unplugged and powered off but it still continued.I had fitted another wheel so I could drive and was testing the Cube wheel in my lap.I noticed as I moved that the UGT software lost and regained connection. I tracked it down to the USB connection to the USB power module being loose. I am able to make it cut in and out with just a little pressure. It was just coincidence that with moving the rig to install the Simucube it moved the connection.

I have reached out to Cube Controls to see how quickly I can get a replacement.

I hope this info helps someone else.


Thanks for the reply at least you solved the issue and Cube Controls should be able to send you a new cable relatively quickly so it’s not a long or expensive fix!

I sent Cube Controls Pictures and a video showing the disconnection and reconnect as I touched the USB connection to the USB AC power. They are sending out a replacement.

1 Like

Great that is good to know especially with a wheel that is that expensive!

Hello guy’s, I’m also a happy owner of the csx2 and Simcube 2 Ultimate.
How do you guy’s connect the csx2 with the Simcube? Because my wheelbase can’t find the csx2. It keeps searching

The CSX2 communicates with your PC not the SC2.

1 Like

Ok, so no problem at all. Thanks a lot!

1 Like

Yup you’re all good!

1 Like

Hi Alex,

As mentioned the CSX-2 communicates with the UGT software on the PC. This is the issue I am have due to a mechanical fault with the Cube Controls AC power adapter.

Strange isn’t it? Or do you just have bad luck?

Another question, sorry guy’s but I’m a really noob with the pc. How can I get the screen working in Rfactor? I put the file in the Rfactor map, but it’s still not working. And in iracing everything works

I have question, trying to find the right forum… this is as close as I could find… I have the csx 1 , it comes w only the usb cord. Its not nearly long enough… Tried usb extension the lcd screen will not run. Does it need the power hub as used on csx 2 ?? Cube control does not list that as an accessory… How can I extend the usb cable on a csx 1. Ty

Contacted cubecontrol, any powered usb extension cable good.