Steering feels notchy


#1

Hi, yesterday I just randomly tried to move my steering wheel with a kinda light touch. To my big surprise, it felt as it would of been stuck, not much but enough for me to clearly notice it. Like there would of been small amount of glue allready dried and holding it in place. After the initial steer it didnt feel stuck anymore, and I didnt pay anymore attention to it at that time. Today I tried again and I discovered that this time the wheel wasnt “stuck” at first like it was yesterday, but now I noticed the wheel has very distinct notches in it (as it is not powered on). Some of the notches require more torque to overcome, sometimes my fingers just slide on the steering wheel while trying to move it. I remember when I got this, I was so happy how it moved freely, compared to my old G25 with gears. Well now it actually feels kinda worse, but only in a different way than G25 gears. Also the wheel doesnt seem to start moving any better after driving a bit and Im also noticing this same kind of notchiness while driving.

AFAIK, this has nothing to do with the software, or the Simucube box, its just motor related

Is there something wrong with my motor? Should I contact the shop that sold me this unit?

Small Mige BISS-C

Thank You

EDIT 4 days after creating this topic:

TLDR: The motor was faulty, and it was replaced

I’m not an expert on electrical motors, and obviously without ”autopsy” we can only guess what went wrong in the motor. Besides being noisy when rotated (the 2 other motors present didnt make any sound), and also the FFb being mushy across the board, which became evident after trying a new motor. Unfortunately, I have to say that the notching is inherit to these motors (at least both other motors notched when rotating without power), but at the same time notching was way more tolerable with the new motor when driving vs the old one. And in roofed cars, the notching was practically absent with the new motor.

When I first got this system late last year, I quickly realized that I need to use max reconstruction filter with it, since otherwise it would give these very hard spikes here and there, around a lap of any circuit and with any car. With the new motor, I can lower the reconstruction filter to lowest, and the torque bandwith limit to unlimited, and still dont get these hard spikes like I had with the old motor. Driving with the new motor, the FFb was way more clear, even with the same settings of max reconstruction filter that I used before. We also replaced the cables, altough it didnt noticeably change anything. One more side note, the first thing I realized after setting the new motor up at home, was that before I got noise from my old Logitech 5.1 speakers when the Simucube was powered on (before I needed to turn the sperakers off to avoid this), and now with the new motor (and cables), it doesnt happen anymore.

Lastly I would like to say huge thank you to Simgear (Finnish), for being very patient and helpful with this problem. In the future I’m not afraid to buy even the most expensive stuff from there, because of this kind of outstanding customer service. Keep up the great work!


#2

How are your motor cables - if they are looped somewhere, there could be notchiness felt while powered off.


#3

Right now, the motor cables are not even attached, and the feel is very, very notchy.

At some point the ‘notchyness’ was so clear, that with both hands on the wheel, turning left and right, the motor rumbled. The faster the movement, the faster the rumble. Turning it slow was notchy. I somehow overcame this worse point by simply turning the wheel multiple times over and over again, but it still is very notchy. Also I think that it used to spin more easily when I spin it and let go of it, now it feels sticky and comes to halt more quickly.

Btw, I allready contaced the shop, since I believe this is a mailfunction which I cannot repair by myself.


#4

Does it feel notchy even with the power off ? than its definitely broken otherwise get a proper drc file for the motor

and when you get it working properly
use :wink:
RCON 8


#5

It sounds like you have a faulty bearing on the front input-shaft of the servo.

Turning it slowly, do you hear any grinding sounds?


#6

All power off, not even cables attached. Trying to turn it slow doesn’t make any sound. I say -trying- to turn it slow because doing so makes it notch in the direction you are turning it, then it goes heavy and stops, then notch forward again, and stop, notch forward… you get the point. Turning it slow in a steady phase is impossible for human hand. It will jump between these predetermined spots while being heavy in between and making it stop. I’m doing this without any wheel, just turning the axel from the QR1. However if I accelerate the rotating speed, enough so that I can actually keep steady phase without it stopping in between, that’s when I start to get noise. Also at this point I can feel the small rumble in my fingers while it is going trough the heavier spots. The sound is like humming, the faster I turn it, the higher pitch the humming becomes. The humming sound comes from the front of the motor.

Thank you for your help, I am currently waiting what is the decision of Simgear regarding this problem.

Also I believe that this problem has came gradually (I might be wrong here though). At first when I got this, after hours of fiddling with the software, I used damping and friction, because the wheel was just way too light for my taste at some points. Then after months of driving and one longer pause, returning I wasn’t happy how the steering felt. It felt too heavy and uninformative. I started fiddling with the settings again, and to my big surprise, I gradually toke all the damping and friction away, and it felt much, much better. I was a bit baffled about this but I didn’t think of it too much back then, since the steering was again fine. However, couple of days ago attaching a smaller and lighter wheel really opened my eyes to the problem.


#7

I stick with my diagnosis of faulty front bearing :wink:


#8

Do you run with any kind of shaft extension on the motor?


#9

Just the QR1, no other extensions


#10

I’ve also had some small notches when pushing my wheel for a while. similar feel as what OP described with a bare shaft with there being like heavier spots upon turning of the shaft. I didn’t really think much of it until this thread. Should I be concerned/contact provider.


#11

I can give a real world example what it does while driving. For instance driving Skip Barber in iRacing, I can clearly feel that there are notches in the steering. Going into a corner, first when I input a certain amount of torque (with my hands) to the wheel to turn the car, with that amount of torque, the wheel will stop (turning more) at certain point, that is obviously perfectly normal, nothing weird in there. However now, when we are at that point, where we allready have some degree of rotation on the wheel, then when I try to turn the wheel more from that point on, then it will only move by notching into its new position. Again if I want to apply yet even more degree into the wheel (getting closer to apex), it will again only move by notching forward. So at certain point, the wheel starts to move by notching. This happens regardless of the FFB strenght I decide to use. I notice the notching more easily the more I turn the wheel.


#12

Is the distance between the notch steps always the same, and the same also when you have powered off the system/ pressed e-stop?


#13

To me, the steps seem to be exactly the same as when moving the wheel when power is off. While driving, I guess I sometimes might skip 1 (or perhaps sometimes even 2?) notches. And like I said, while driving the notching seems to be more dominant the more I turn the wheel, after about 45 degrees or so in either direction, right when the motor is starting to generate more torque. But at the same time it does that no matter how weak I set the FFB. With weaker FFB its just a bit harder to notice, but it’s there. Its weird really. This whole thing really became obvious after going to a much lighter and smaller steering wheel.


#14

I would try removing the wheel and button plate from the drive lock rotate wheel and button plate 90 degrees without moving motor shaft and re install wheel and button plate.
Then go into motor configuration and center the wheel again.

Drive and test to see if you feel the notch in the same place.


#15

Or maybe it’s not mechanical, one can never be sure what is standard cogging and what is not, based on feedback in these threads …the only way to know for sure is to test it for myself…blah, so difficult to troubleshoot existing and non-existing issues sometimes…


#16

Yeah that is why I thought about changing center position.
I would not think a Mige bearing would go bad unless it was in harsh conditions.

I remember Aussies saying that Aluminum will corrode quickly if it is not sealed? But I do not ever remember anyone having a bearing issue.

In fact over all of these years I only know of 2 factory installed encoders that have failed.
Many more of the self installed Sincos have failed.


#17

I’ve allready changed the center position many times, but it doesn’t help the notching. I’ve changed it by simply rotating the wheel while Simucube is powered off. Then when I power it back on, it will change the center position to where it is now (or near it). This is how I actually got rid of the worst rumble (and micro shaking) that I had with some of the ”area”.

I just dont get it why the notching always becomes more noticeable after a certain amount of steering degree, regardless of the FFB settings.


#18

If you do not physically unbolt and then rotate the wheel and rebolt you are not changing the center position.

If that does not make sense, sorry I have no more ideas for you.

I would highly doubt it is the motor. If the person you bought it from is willing to exchange the motor for you it will be interesting to see the final result.

It is possible that the encoder has gone bad and is causing your issues, but it is very rare.


#19

What simulator are you running this in?


#20

I usually only use it for iRacing.

So my take on this is, that there is something in the motor unit itself (whatever it is) that is braking the movement of the motor, which is creating this whole problem. This is evident that the motor unit is producing these notches, because those notches are there weather the Simucube is on or off, or even if the cables are attached or not, the steps can still be felt in the motors movement. So those steps must be produced by the motor unit, no other explanation. Clearly they cannot be created from the Simucube, Simucube software, or from other external things like looped cables or whatnot. Because they are not even attached, and yet the same notches are allready in there.

These notches (or steps whatever you want to call them) created by the motor unit, are then multiplied once the tyre friction builds up ingame. Making the notching very clear. Or something like adding friction from Simucube software, and not using any other software to produce any other forces, will show these steps also more clear. It makes sense, adding friction on top of the friction creates even more friction. The original problem must be the notces in the motor units rotation.