SQ2 Pro No FFB Across All Sims

Hey guys,
Just bought a SQ2 Pro a few days ago, just got everything setup yesterday. Everything has been mostly fine, feels good. But now I have no FFB across all titles. The steering input is picked up but there is no ffb put out by the motor. This is very frustrating, does anyone have any advice?

E-stop? You need to twist it to unlock.

E-stop is unlocked, any other ideas?

What’s strange is that the ffb came back after I messed with the settings in RBR, now when I come back today I have no ffb again.

Is your SC2 direct into the PC or via a hub? If your not using a USB hub try another USB port and see if the issue persists. And what firmware are you using?

It can’t be the main power cable going to the Simucube, can it?
DON’T FORGET TO FIRST UNPLUG the cable going into the wall socket !

does “reset FFB Device State” button on the last tab in True Drive help at all?

It does not sadly. Here’s an update on my situation. I went to back to microcenter and exchanged the SQ2 Pro that I had for a new one and just got everything set up a matter of minutes ago. I am having the same issues. I will attach my wheel settings to this response.

Turn off Q-factor, attentuation and center frequency. I think that setting the frequency to 0 disable all.
You are kind of lured into thinking, wherever there is a slider I have to use it. Do a simple preset:
Torque to 50
900 degrees
Recon 1
Unlimited bandwidth
Everything else to default
Direct input filters mostly don’t work, to start just leave them at default aswell.
What simulations you have?
AC, F1, ACC? I would start with something simple, without a ton of additional apps, Mods Aso. Especially when I am in trouble to even get it work.
If your steering wheel and pedals are working, everything is properly addressed, make sure you have activated the Simucube as main device.
If I understand you correct you didn’t have a Simucube 2 yet (only the one that didn’t work). I can’t imagine that the store gave you 2 new Pro and both are defect.
Maybe you have a very good reason to use the notch filter together with the settings for DB and Q-factor. If so, please let me know. Only saw theoretical explanations, never a real example

As you have the same issue with two wheel bases, it is very likely an issue with your PC. It might be a third party app that interferes somehow.

1 Like

You turned the “Slew Rate” down to 0!!! =) Find the mistake!

The third graph shows your FFB. The Blue Line! You don’t have FFB because you don’t allow your SC2 to give you FFB!

Set it to 1Nm/ms for now. My personal first point of attack is 0.65Nm/ms. Doesn’t matter!
At 1Nm/ms the FFB signal looks like this. (The calculated FFB singal is disturbed)

Another point of view is this. These are the FFT’s with and without “Slew Rate”. This tells you how often a frequency occurs. The FFT below shows your frequency response with “Slew Rate”! (at 0Nm/ms it just shows blue, but there should be anything there)



Your setting for the peak/notch filter isn’t exactly optimal either! More on that later!

Just as an example:
This is the frequency response of the Eau Rouge / Raidillon. The frequency of the Eue Rouge is 0.3125Hz (T=3.2s).

If you set the notch filter to 1Hz with a Q factor of 0.5 and then lower that by 3.1db. Then you reduce your FFB signal by about 50%. In summary: You have practically switched off your FFB via the “Slew Rate” and reduced your non-existent FFB by another 50%.

I think a compliment is in order now. Simucube2 is the most advanced wheelbase that you can buy for money. But you can really make problems with it if you don’t understand it. Granite Devises did a great job!!! Thanks!

Slew rate 0 means no limit, i.e. using max.
This setting always confuses people.

You’re right! I just noticed it now.

Then KT555 should first focus on the equalizer. Because a reduction so deep in the frequency band could also be the only problem.

Try these settings.

His EQ should look like this.

PS: sorry for the excessive pictures.