Simucube2 Ultimate PSU switch and beep noise

Just got my Simucube2 Ultimate, loving every bit of it so far, just tried ACC for now, will get to iRacing AC and rF2 soon ish…

Wanting to know if it’s safe to leave the PSU powered on permanently and use just the remote power switch.

Also when left on there’s a beep from the motor every few minutes, what is it and how can it be turned off? Is it a high torque warning?

If you stop using the wheel and don’t turn it off, a beep sounds every 2 minutes. It’s normal, and you can’t switch off (it’s a safety standar)

Well I am sure there is a way !!! Just will require voiding your warranty… how much does the beep bother you ???

Press the e-stop…and no, there is no other way at the moment…

1 Like

We are working on improving the beep feature for next release.

the Beep is being done via the motor it self, there is no separate audio-producing component that you could disable…

Yep, that was what I was alluding to in my reply, haha. Motor-coils are used to generate the audio - so if he disables that, then no more ffb…

Sorry, I found his comment just funny, that’s why i replied again just now.

PS: Greetings from Tokyo!

Thanks all, not an issue, just a curiosity.
How about leaving the PSU switched on permanently and only using the power button on the e-stop? Safe to do or no?

Yep, safe to do, that’s how I have been running since SC1 days, quite many years and zero issues.

Surprisingly beeps donts bother me dont even notice it. I have loud music playing usually.

The profile not switching is a bigger bother than safety beeps which can be negated by pressing the e stop

Thanks, makes it easier as the e-stop is mounted to the rig while PSU is a bit out of the way

Cheers Mate, you’re welcome :wink:

This beep is annoying like hell and we should have a way to remove it.

I don’t think it is your responsability to enforce a “security” (against WHAT ? Wheel turning itself after 5 minutes if I don’t use it ? Seriously ?) and EVEN if it was the case, this is MY problem, not yours.

So please, allow us to remove this EXTREMELY annoying beep that does nothing but just…noise.

See the firmware changelog for next version. There will be just 3 beeps and then a standby mode, which will be easy to get out of, and user can prevent the standby mode.

1 Like

So the SW does not allow to disable standby mode? When my Sumicube2 Sport goes in standy mode the TrueDriver SW freezes!

That freeze should not be happening and is new to us.

So is there a way to disable standby mode all together? We have purchased about 6 units so far and looking to buy many more but cannot have the wheel go into ‘safe’ mode after ‘x’ of minutes of inactivity. Being able to remove this feature would be a huge help for us. :slight_smile:

Thank-you Mika,

Would running a previous version; like 1.0.10 (September 26th, 2019 release) fix this issue temporarily for us?


There is no public way (and no simple non-public way either) to downgrade firmware to 1.0.10.

We will implement a permanent high-torque mode with disabled standby mode and no beeps for the release after the next release, due out in Q1 2020.

However, if you can’t say to sim users that they should toggle E-stop to re-enable torque, then it raises questions on whether you have safe instructions for users for DD wheels which can have high torque.


Is there a way to disable all audible notifications… completely? I have tried disabling the audible notification option in truedrive however it still beeps upon coming out of standby mode. I live in a fairly small space and work shifts. I can hop in the sim rig at any time of the day and I don’t want (and my wife doesn’t appreciate) the beep going off in the dead of night. I understand it’s a safety feature, I get it, but please give me the option to turn it off.