- simucube2 - E-stop is pressed issue

I have post this early but with a less clear title so I think i should re-post the topic and might be more ppl can share this if we have the same issue.

Almost everyday I have this ’ E-stop is pressed ’ issue and the only way to make this work is to turn off the simucube 2 and turn it back on again. I believe it is a software related issue because i do not have any other time having the similar related issue at all. What i need to do is simply turn it off and on, it doesn’t matter what other buttons i tried, it won’t work.
Operating Mode is also showing - waiting for drive to get ready instead of Operational

when the ‘E-stop is pressed’ shown in TD, I have 2 different circumstances. Either …
1: no any feedback at all as expected
2: or there is a force activated but of course it won’t work in game. Beside there is a force there but TD shown no other sign it is working. ( the steering in TD won’t follow my movement )

I am just wondering if any of you have the same issue or what is the solution, it is getting frustrating with this long term issue for me.

Please share your experience, Thank you

I had this happen a couple of times a while ago (previous firmware), but not had it recently at all.

Maxx, which FW version are you running? But anyway, I am sure Mika will identify and fix the issue for you, if it indeed it is in the FW.

Cheers,
Beano

I flagged it to Mika already and just wanted to check it out if I am the only one or other might have the same issue.

I am using the following :
simucube2 firmware 1.0.18
simucube2 software release 2020.4
Servo drive firmware 10821
Simucube2 PRO

All good, yes, I saw it was posted in another thread earlier too.

It is an interesting issue - I haven’t been able to repeat it for any reason, while Tero also said that the servo drive is not susceptible to hanging at the initiation step due to e-stop signal being bad/inconsistent. So, no idea on where to begin finding the cause.

@Maxx, I have read in other thread that it’s happening when you just turn on servo and launch TD.
Do you launch TD after servo makes that initialization beep, you e-stop should be disengaged for that to happen.
My experience is if I do not follow proper timing and order, I see issues like that or something like “initialization fault”.

  • disengage e-stop (twist button)
  • turn on servo
  • wait for double beep
  • start TD
2 Likes

I tried different combination, all works when it wants to work. I don’t find a pattern to repeat the issue yet.

Sounds like it might be USB issue. Have you tried different port or computer?

Its not an USB issue, as the “waiting for the drive to become ready” -> “Operational” state transition happens inside the device, regardless of there being USB communications or not. Some similar issues were already in the firmware during last summer, then they suddenly fixed, and it seems some of them are back. We are thinking if the status and profile/hardware/analog axis data requests by Simucube at the point of time in the device startup are causing some weird timing issue.

I’ve tried to repeat all kinds of timing issues for this last summer, and couldn’t find / replicate the issue.

1 Like

Thanks for clarifying Mika.
Yes, last FW update seems to fix “initialization failed” issues for me.

I can replicate the issue if I try to write to simucube while in ‘waiting for drive…’ mode. Like if I try to edit a profile before releasing the e-stop.
I don’t remember if that’s what I did every time the issue occurred, but i’ll try to be more conscious of it from now on and see if it happens again.

Hi Mika
I believe I did reproduced the problem in my case. I did 4 times in a role on puropse which will cause E-stop is pressed shown under the mode - waiting for drive to get ready, If i do the following order.

1: Launch TD
2: Turn on Simucube 2 Pro
3: Change the profile - THIS IS THE PROBLEM
4: Release the Emergency button

4 times in a role on purpose which has the same issue, but if i switch a step which will have no issue like the following

1: Launch TD
2: Turn on Simucube 2 Pro
3: Release the Emergency button
4: Change the profile

Then all works fine.

1 Like

My order with no issues:

1.Turn ON SC2
2.Wait for beeps (Windows & SC2)
3.Launch TD

No problems, Never touch E-Button, allways released but in emergencies

4 Likes