SimuCUBE with stepper motor

Good morning,

I am planning to build a direct drive sim wheel system using SimuCUBE and an IONI driver. I have a bipolar stepper motor that I would like to use for the project.

(I know that stepper motors are not the best options for a DD wheel due to their operation principle and the higher cogging torque, but I had this motor before I decided to go for SimuCUBE, so I would use this if it is physically possible.)

My question is that can SimuCUBE with an IONI driver drive a bipolar stepper motor at all?

The Wiki page of the product is a bit confusing to me. It says that IONI driver can drive stepper motors in 3 different configuration (open loop, closed loop and serve), so this part is OK. Also, SimuCUBE board has 4 motor connectors and according to the Wiki page (https://granitedevices.com/wiki/Connecting_motor_to_SimuCUBE) 2 phase stepper motors can be connected. This suggests to me that I can use the motor I have. However, I can’t see any examples on the Wiki page and on the internet that a stepper motor has been used with SimuCUBE, all documentation refer to servo motors. Plus, I couldn’t find any wiring information for stepper motors to SimuCUBE.

So, could anybody please let me know if SimuCUBE HW can be used with stepper motors for DD Sim wheel application?

Thank you in advance.

1 Like

Hi Polik

Stepper motor can be used with simucube, as IONI indeed can drive it. Simucube only gives IONI torque commands, and IONI handles the motor. To use a stepper, you need to first tune the torque controller properly.

https://granitedevices.com/wiki/Using_stepping_motor_with_IONI

Kind regards,
Esa

Hi Esa,

Thanks for your answer, it’s much appreciated.
It is what I suspected, but it helps a lot that now I know it for sure.
Thanks again.

Kind Regards,
Zoltan

Hi again,

The project is going on, I have ordered a SimuCUBE and an IONI Pro for the stepper motor.
I have wired up everything and set the system up according to IONI and SimuCUBE documentation in Granity and Simucube Configurator.

The problem starts here. When connecting and switching on everything, the Simucube Configurator recognizes the setup, the virtual wheel on the screen turns when I turn the motor by hand (so encoder reading is OK), and the torque of the motor is changing with the angle. But, it doesn’t work as it should. Instead of pulling back the wheel to center position, the motor always locks the wheel in the actual position. Closer to the end position, it needs more power to turn the wheel, closer to the center position it is easier. But it never moves automatically, the motor always holds it in the acutal position. In the end position, the motor locks massively, it does not even come backwards, it needs high power to rotate it back to the normal operation range.

Does anybody have any idea what I am missing or doing wrong?

In the attachment there are pictures of my settings, but I couldn’t upload a video of the operation. If anybody could give any hint how should I make a step forward, I would really appreciate it.

Thanks,
Zoltan

What type of encoder is on your motor - is it really 1000 PPR?

It is an incremental quadrature encoder without index.
The PPR is really 1000 resulting in a CPR of 4000. I have even measured it by an oscilloscope to make sure. :slight_smile:

I know it sounds low compared to encoders can be found on servo motors these days, but it still should be able to detect the 0.27mm movement of my 350mm large steering wheel, so I reckon it should be enough.

Set foc at max although that is not your problem. Does it really have that much motor pole ?

Thanks for the comment, I will try that.
Yes, it is a bipolar stepper motor that has 100 poles. I guess the motor type is somehow in connection with my problem, I just couldn’t figure it out how. I have set the motor up according to the guidelines (see below), so I suspect it should work… but it doesn’t. :thinking:


Have you tried those 2 options for invert ? Axi or fbi , i mean.

Not yet, will try tomorrow as I am working on another part of the system now. :slight_smile:

Ok, I have tried inverting AXI and FBI… and it solved the issue, now everything works perfectly. Thanks Loukas, I owe you a beer. :smiley:

I thought that simply wiring up according to the datasheets should be good, but apparently phase 1 and 2 mean different things for the motor and the board manufacturer. It’s not a problem though with the ability to invert the channels in SW, so I will be aware of this in the future.
Thanks again for the input!

1 Like