Simucube Unknow Usb

Hello, I’m trying to make my Simucube with small midge working but it’s really hard.

At first, I’ve configured it with my dad computer’s and it was working fine.

After that I came back to my house and try to make it work on my computer.

For this moment, when I plug it, it says USB Unknow and isn’t recognized at all.

Since even got some problems with my Oculus Rift S related with USB, I’ve tried to change my motherboard and processor(Ryzen 3600 with B450 Gaming Plus Max Mobo) , this Is what I have done.

And with that I’ve made a Fresh Windows 10 install.When I was making all of this a friend came home, and we tried it on his computer, it worked perfectly, but when the install of the fresh W10 has been finished (With all updates), I’ve been surprised when I saw USB is still not recognized…

Any advice?

Hi,
Try install manually driver
https://ftdichip.com/drivers/vcp-drivers/

I really start to think windows as kept all the drivers from the previous installation , i have formated the Hard Drive , but it was already install so i dont know .

But as a surprise , like every day it’s Something different , the simucube has been recognized but know its time for simucube software to not respond every time i launch it … (Already Reinstalled)

Simucube usb ports could be recognized sometimes , or sometimes it could be not , but in all case he cant connect to the drive , and ioni usb isnt recognized at all

This is the UsbDeview Report , I really dont know what to try next