Simucube suddenly stops working and device manager error

New Win 11 build.
Using latest Simucube 1.0.40.
Do not have granity on my drive, but pretty sure that’s unnecessary anyway.
Simcube has been working fine, until today when I tried to launch iRacing to find that no wheel was detected.
Inspecting Device Manager shows the following error under the USB controller section:

"Windows has stopped this device because it has reported problems. (Code 43)

A request for the USB device descriptor failed."

Tried power cycle everything (including PC), using different USB ports etc.
No luck.
Simucube has power and I can feel the usual resistance in the wheel, so pretty sure it’s not a mechanical problem or anything to do with the SC1 electronics as I’m seeing solid green lights inside the SC1 enclosure.

I seem to recall a similar issue with an other USB device a few years back, and the solution was to reset my motherboard’s CMOS because once the controller was locked, Windows essentially would not allow it to work, and I could not find a solution anywhere.

I will try this and report back, but would appreciate some help if someone knows of another way to resolve this?
Thanks!

UPDATE: - BIOS CMOS Reset on my PC did not resolve :frowning: HELP!

1 Like

Search download and install Microsoft c++ 2010 redistributable.
Then install Microsoft c++ 2015 redistributable. And then the patch for the same.

I just helped someone who recently built a new PC and that is what he had to do.

Apparently the SC1 manual at the Simucube Wiki also has this info in it now.

Thanks Joe.
Tried this ,removed the already installed redistributable, restarted my PC, reinstalled it again, restarted again. Then plugged in the Simucube and same exact error.

I am stumped.

Did you try to remove offending USB device from device manager?
Right click, select uninstall, reboot PC.

Visual studio redistributable files have nothing to with Windows detecting device drivers.

Andrew’s suggestion is good. Sometimes it is good to uninstall the whole USB hub.

After many painful hours, ended up resolving this by using an old ‘USB Serial Converter’ driver (FTDI v2.12.28.0 - from 8/16/2017) instead of the updated one (Year 2021) Win 11 installed.
This was the last entry under Universal Serial Bus Controllers in Device Manager.

Bizarre indeed, and glad that I am a hoarder of drivers.

1 Like

Where do you find those drivers? Cant find them
If you have a link , i will take it :slight_smile:

Found it , but still the same error , dont know what to do

Does it do the same on another PC / laptop as well?