Simucube showing as unkown usb device (Solved)

Hey ive had no luck getting my simucube to work at all. The last thing i remember doing that could effect it was that i deleted the true drive software off my desktop then put it back on again. I doubt it would have even updated the base, still had my profile settings and worked for a short amount of time… Status led flashing blue red. Also will still turn green if i rotate the wheel out of position. I have cycled the power, checked the stop button, Tried it on another pc and im at a loss

Update: just realized i did the dumbest thing and destroyed my usb cable moving the pedal plate on my rig. And boy does the cable look hard to fix.

So on a sidenote does anyone know the specs for this particular usb cable for when i fail to fix this

There aren’t any published specs that I’m aware of. If you select a new cable that has ferrite cores attached from a reputable company you should be good to go.

1 Like


The USB cable is generic/standard USB 1.1 (or better) cable. We recommend using only shielded cable with ferrite cores to shield the cable from possible EMI interferences.

Kind regards, Esa

Many of us received SC2 with non shielded cables missing ferrite cores.
Not a huge deal as they are widely available, but why would manufacturer include cable it does not recommend to use.


Availability of such cables was very bad/expensive at the time, so something had to be done.

Or rather, somebody had to go out and pay for them, meaning the customer :joy:

1 Like

Thanks for all the replies.
I think the shielding in the cable intimidated me a bit but i managed to re connect the cable by heating up a meat skewer to solder the wires back together as i lost my soldering iron. Then i just did a wrap in aluminum foil around the wires then the ground wire and a bunch of tape. Works fine till i get a new one for piece of mind

1 Like