Simucube Set up - Error 140403


New user on here,

We have 8 Sims currently on Simucube 1, and have had a lot of issues, after some time we have gotten most of the working and left with 2 main issues.

Sim 1: Error 140403

  • We replaced the USB Cable - this helped with one issue of the simucube being disconnected completely

  • Error 140403: After playing PC2 we would notice red light flashing on Simucube, we have looked at the error code and clicked on the help guide suggestion which reads

Velocity exceeded the limit defined by Over speed fault FEV Increase Over speed faultFEV or avoid running motor too fast

When I open granite deivces and try clicking on the button to increase FEV it stays on 0.00 and will not allow me to change, now I did try on the other sims to increase the value and none would let me, but we only have error 140403 on this sim.

I have swapped the Power Supply and still same issue, I am thinking we have a bad simucube board that we need replacing.

Will anyone be able to help out, I be happy to remote screen share the device,


You need to click “Enable IONI Configuration Mode” button in Simucube, then connect to servo drive via Granity by using the X4 USB port, and then change the FEV setting. It cannot be changed when you have not connected to any device with Granity.

Any values that show as 6 rev/s are good.

And, I will be getting back to you on the support ticket you have, tomorrow or the day after.


I don’t think we have ever done this, as we did not no this is how to do it.

I happen to have a spare board on my desk and found a cable that looks like it will be correct one,

Regarding "X4 USB Port would you be able to clarify exaclty which one this will be, will the cable in the image be the correct one to use,

I will

Step 1: Enable IONI Config Mode
Step 2: Connect the cable shown
Step 3: Open Granity
Step 4: Change FEV Value to 6.00

Is this correct?

Thank you for the help Mika

Connect the mini USB cable to the X3 port so Simucube Configuration Tool can communicate.

Click Enable IONI Config Mode button.

Switch port to the rightmost port (X4).

Use Granity to connect to IONI servo drive, and change the FEV setting to such setting that the text next to the field says that the limit is more than 6 revolutions per second. Save settings to flash there also (it will prompt to do that before disconnecting). Click disconnect.

Then switch cable back to X3 and disable IONI mode.

Thank you For your help,

I will be doing this in the next 24 Hours when Im with the sims,

I will then update firmware also the latest
October 6th, 2021 1.0.40 / 1.0.39 10720

Hopefully these Updating the firmware will fix the wireless wheel issue
and connecting via X4 should let us update the FEV Value to 6? to fix error 140403

I did not expect the amount of help received, has put a lot of faith back knowing theres this support


I apologise for the trouble

I did read the article but I may have not understood clearly

I’m not familiar connecting to Granite Devices

Currently the Simucube is connected as we playing with Error 140403

I connect the big USB onto the top right port and connected it to the PC

I Clicked on enable ioni usb configuration but when open failed to find device

I am sure I’m missing a step or doing wrong port, are there any videos of someone doing it from the very start

If step 1. , step 2 with pictures is available it would be really helpful


Uploading: 668877F5-7753-4305-B167-29984333E28F.jpeg… Uploading: 63649C5F-18D0-473D-8ADB-5676AD9B6BA6.jpeg…

Those big 4 ports are not USB. I hope you didn’t short out your Simucube board.

You connect USB to the small USB ports on the right side. I would plug both of those cables into your PC.

In the picture I see you just have the Simucube board out sitting on a table. Take extra precaution not to touch the board with static electricity in your body. You can easily kill the chips if they get zapped with ESD.

Step 1:

Connect Mini USB to the X3 port.

Step 2:

Open Simucube Configuration Tool and click “Enable IONI USB configuration mode” on the last tab.

Step 3:

Switch the mini USB cable to the X4 USB port.

Step 4:

Open Granity. Find SimpleMotion COM port on the connect tab, click connect, drive at address 1 should pop up and select it

Step 5:

Go to Fault Limits tab in Granity. Change the Overspeed Fault Threshold [FEV] paramameter to such value that it shows as 6 rev/s next to the field (or faster).

Step 6:

Go the first tab in Granity. Click Apply settings from the bottom.

Step 7:

Disconnect button in Granity. It will prompt to save settings to flash. Click save.

Step 8:

Switch cable back to the X3 USB port. Click “Disable IONI Configuration Mode” in Simucube.

Thank you for the detailed instructions, very clear and helpful and did exactly as needed, super helpful.

I will see how it performs in next few days

Also we have the same error come up on a separate machine and did the value change on both now,

Can I ask what can cause it happening, and the value can be set much higher I ended up going with 100 = 6.25, what does a higher number mean / do.

Regarding the open circuit board, someone else has done a poor job installing the sims and I’m currently just trying to get them working and then I want to go one by one and secured and safe them.

Iv attached images below for reference

It is a software limit for robotics applications, the system will go to fault condition on run away event, for example. The value to put into the field is in encoder counts per second. Higher values mean that the axis can rotate faster before triggering the fault.