Simucube Pro Not detected

I purchased Simucube Pro, after assembling and installing it, I found that Simucube Pro was not being detected by the Windos 10 pro system. In the firmware update process I checked the errors attached. I tried to solve the problem as follows:

1- connect the simucube to different usb ports
2-update the motherboard drivers
3-plug the power supplies into another outlet
4-turn the simucube on / off several times so that it can be detected and installed by windows.

All of these steps were done without success.

I also found that when turning on the Simucube it does not give any sound signal, is this normal?

Help please!!!

1 Like

Try the emergency button.

I already tried that

Hi. The emergency stop button is release? This is important to update the firmware

1 Like

It might not be obvious but you need to twist it to release.

Yes, the e-stop button is released. Windows did not detect simucube 2 in device manager.

Did you try a new good quality USB cable? SC2 will not initialise without this connected and detected proper.

Uns, i already tried another usb cable with no success :frowning:

Is there a light on the psu?

Windows don’t give a register sound ether when connecting?

Your motherboard support usb 3.0?

Also IF there’s a fault with your emergency button it won’t registrer. (Try make sure it connected propper)

Follow the manual connection order to the point.

Watch the official video guides on youtube.

If none of those works. Take contact with your reseller. They will help you


thks, problem solved. Windows
drivers problem


If problem is not solved try disconnected all USB devices not needed to operate pc.

See if wheel will connect.
After it stays connected, start reconnecting USB devices one by one and you will figure out the conflicting device.