SimuCube OSW Resistance Insufficiency Problems


#1

Hello,

first of all here is my setup:

SimuCUBE based OSW kit Biss-C - with Acrylic case
ServoMotor: MiGE 130ST-M10010 Biss-C - 4,2 mil cpr
PSU: Mean Well 480W (Noiseless) 20-30Nm
Servo drive: Ioni Pro HC (25A)
Servo Cables: Black MiGE Fully shielded cables with CNC machined connector

SimuCUBE Firmware, Configuration Tool and IONI Drive Firmware version all up to date to latest version.

I tried to setup the OSW today and went into an issue. I followed the starting and quick start guide provided by SimRacingBay for the OSW. Everything worked fine, until I tested the wheel the first time. There is a weird feeling with the wheel turning it around.

I try to describe it like it has different areas of resistance, – high resistance - low resistance - high resistance - low resistance – when I move around the wheel. I made a video which hopefully describes the issue: https://www.youtube.com/watch?v=MYoPLdl83wI

I also tried everything from different .cpr settings, older/newer simucube SW, checked proper fixation on shaft, configuring over granity SW, and even on different computer. The issue stayed the same. I also went through every single setting and the diagnostic information in granity (also together with people that have the same setup as me).

We have a guess that it might be the encoder, although the diagnostic data and settings are all fine in Granity.

I hope someone from the Granity can maybe help me and maybe this is a known issue.

Thank you very much in advance!


#2

Just to chime in on this I took a look at his settings and everything was ok. We double and triple checked granity and even swapped in a working drc file that Brion provides. Essentially his issue looks like some sort of notching and “steps” as he’s moving the rim from left to right. It’s not a smooth motion. We took a look at his feedback position sensor and the encoder is reading. It’s an odd problem and one I have never seen before. So I hope someone in here can shed some light on this issue. Would not be surprised if its an encoder problem.


#3

The Video looks like wrong encoder settings, but could be encoder failure. There have been very few encoder failures, so that would not be my first guess.

I would first upgrade simucube software and start from scratch.

Be aware that the last simucube firmware had a minor bug that you had to enter the bump stop settings to a non standard value then change back to correct value. This one caught me out as I had zero endstops and FFB. I nearly pulled my hair out trying to solve that one. :slight_smile:

Have you contacted Tomo?


#4

Yes we did send Tomo an email late at night so we’re still waiting on a reply but knowing Tomo the reply shouldn’t take long. We’re pretty much stumped at this point since we took working drc files and pasted them into his setup and it kept doing the same thing even after recalibrating the motor.


#5

Hey Joe,

thank you for taking time to answer.

I will test out that bug you described later today.

Nevertheless we got an answer from Tomo already. He is sure its probably not the encoder as its diagnostic is fine. He thinks it might be a broken cable or maybe the motor. I am receiving new parts mid of next week and keep you updated here.


#6

Looks like either wrong encoder settings, or switched any two motor phase wires compared to the settings. Switch any two motor phase wires, or switch AXI invert setting in Granity.


#7

@Joe: I tried your suggestion, it didnt help unfortunately.

@Mika:
Hello Mika,

thanks for your reply. Really appreciate your support.

I set up the OSW today again and hooked up both USB cables in order to startup Granity. Unfortunately - when I connect the one for the Granity SW - I now get a windows pop up that the connection could not be established, as the device is not answering properly. Thus I can not load it anymore in the Granity SW (although I prepared the connection in the SimuCube SW). The initial problem with the different resistances on the wheel is still there and the same.

I just tested the cables seperately on the “main” connector to run the SimuCube (NOT combined with the port for Granity SW). 1 cable works, the other doesnt (same error response as described before). I used the exact same ports on PC. I think for this case its really a cable issue ( I never experienced that before …).

I tried this on different USB ports and on 2 independent PC systems - same effect. Unfortunately I do not have other USB cables to test but I just ordered 2 new ones that I will probably get on monday.


#8

Wow… I am sorry for the spam, but yea I dont know anymore… Theres like no system behind the whole behavior of this. So heres my recent observation:

I tried connecting again to a 3rd PC I have. I got Granity running on that one. I switched the “AXI Invert direction” setting from ticked to unticked.

It did not help with the initial “changing resistance” problem.


#9

Ok, then you probably have some wrong settings for the motor and encoder.

Which motor and encoder do you have? Is this a DIY build?

On the first two computers, are they windows 7, 8 or 10? It is known, that too old version of the FTDI serial chip virtual COM port drivers (needed for the IONI usb port (X4 USB) can cause issues. Download the latest drivers from here: https://www.ftdichip.com/Drivers/VCP.htm


#10

I have ordered from SimRacingBay. Tomo is also aware of the current status and his latest suggestion is that he will send me a new motor and new servo cables next week.

I have

SimuCUBE based OSW kit Biss-C - with Acrylic case
ServoMotor: MiGE 130ST-M10010 Biss-C - 4,2 mil cpr
PSU: Mean Well 480W (Noiseless) 20-30Nm
Servo drive: Ioni Pro HC (25A)
Servo Cables: Black MiGE Fully shielded cables with CNC machined connector

As said we already tried different encoder settings including the provided .drc files by SRB and the ones that other people are using with the same encoders. Nothing helped.

Regarding Windows:
PC 1: Windows 8.1
PC 2 & 3: Windows 10

I will install the drivers you mentioned on all machines.

Thank you!


#11

Tomo will fix you up.:grin:
I have only encountered 3 bad encoders over the last 4 years, but that is what it looks like in the video.


#12

So did he :slight_smile:

I received a new motor with encoder and new servo cables today and replaced them. That did the trick, everything is fine now :slight_smile:


#13

Great! Enjoy your new Simucube system, and please feel free to ask if there are any other questions!