SimuCUBE Open Source Firmware Public Beta release thread


#43

But having thought about it all my crashes on PC2 have been either when changing ffb settings or remapping buttons.

Also I could change the volume by one click and then the ffb would feel very noise in feel and sound and crunchy. Worst I’ve ever felt with a osw. It’s happened a few time but would go if I rerun PC2.


#44

on point

nr4. iracing crashes before starting another sim first.
nr3. it crashes strait after a fresh pc start too.

sometimes it works on the first try to launch it.
but now i needed 3 or 4 try’s before i got it to launch the game properly and not crash

and all crashes refer to pid.dll

UTC: 26-Sep-2017 12:35:02
App Name/Ver: iRacing.com Simulator 64-bit DX11 2.25.3.12
App timestamp: 0x59BFEFFA
Offset: 0x00007FFC41752456
Exception: 0xC0000005 (STATUS_ACCESS_VIOLATION)

stack @ 0x000000000D1BF570
App Base=0x0000000140000000
Warning: Trace may contain false entries…
0x00000001407F385C @ +0x03A8
0x00000001407F68AF @ +0x0488
0x00000001407F6BE3 @ +0x0558
0x000000014059E276 @ +0x05C8
0x000000014092BF80 @ +0x0718
0x00000001407C4B1A @ +0x07E8
0x00000001407C4BE4 @ +0x07F8
0x000000014068D8B7 @ +0x0818
0x0000000140636279 @ +0x0868
0x000000014095934C @ +0x0898
0x0000000140528037 @ +0x08F8
0x0000000140957666 @ +0x0958
0x000000014038C76F @ +0x0988
0x000000014038C98E @ +0x09B8
Finished
Exception Module: C:\Windows\System32\pid.dll


#45

Brion what value are you setting MPP on SDR-480-48 build?


#46

Moved my post to this thread from the update thread,

I tried Euro Truck Simulator 2 and there is some issues, game is not on supported list so maybe just fyi.

The steering range works fine, in game ratio is correct.
No forces at all, friction, inertia etc, seems all reset to 0 when entering the game.
In controller configuration, every change of key/axis (simucube or not) freezes the game for a couple seconds (but works fine in game)
ETS2/ATS ffb worked as expected with MMos


#47

Hi, I’ll re-post this from the bug thread:

Since I flashed to the Simucube firmware, in Assetto Corsa, I sometimes get a pink screen and crash back to UI if the full ffb rate is running, or just crash back to UI if half ffb rate is ticked.

Before this I was running 1.15.1, & mmos, never had this issue

Windows 10
Gigabyte EX-58 DS4 motherboard
GTX1080


#48

I have a similar problem with rFactor 2, when I try to launch a session, it crashes with message “rFactor 2 has stopped working”

When I plug out the wheel, the problem goes away.


#49

In Assetto Corsa, there is no ffb when the car is not moving. when I turn the wheel, it is just completly free.
With the mmos, there was a rubbery feeling when you would turn the wheel with the car stopped.

It is like there is only self aligning forces.

But when the car is moving, there is more detail than before.


#50

Dampening hasn’t been implemented in the new firmware yet.


#51

Doesn’t that just reduce the sharpness of inputs
?
How will it help me to feel any resistance when not moving?


#52

AC uses dampening (issuing dam commands) to give weight to the wheel at a stand still. Dont think its used any other time and unless someone else know if it does. You use dampening in the firmware to reduce sharpness. Different thing.


#53

Cheers

Any idea when that might be implemented?


#54

Usb bug fix next Game support after that.


#55

Anyone know what the USB polling rate is with this firmware?


#56

USB Polling Rate is set at 1000 Hz in the USB HID Device Descriptor report and it is also the maximum supported in USB Human Interface Device specifications.

However, currently new USB commands to STM USB HAL Driver is send at around 10 kHz. As I went through the code, it isn’t supposed to actually send a new HID report to PC at that rate, only the transmission/report would get reset with a new report content at that rate. So, I’m still thinking whether the reports still get as far as to the PC at the 10 kHz rate - that would also explain the F1 games stuttering. Also Nick (NL Print, the iRFFB developer) told me that the rate is not 1 kHz at the moment.

So, this is going to get some serious debugging attempts during the coming week. Lets see what my findings are…


#57

It’s hard to describe, but with the new firmware, I feel like I’ve got a better connection to the game, it’s like I have better initial direction change.
It feels more fluid and faster


#58

the wheel even makes the irffb app stutter. irffb does work dough and i have 360hz ffb in iracing. but the app runs really laggy with a simucube firmware. mmos didnt have this problem.


#59

Your lucky it buggy with me. I get no ffb and then it will randomly pull left or right.
Try it for the first time to night.


#60

Just rolled back .8 to .71 to test Irffb. With .71 I getting no ffb at all no pulling to the left or right as in .8


#61

Version 0.8.2 will be out any minute now.

Change log, user guide and download links:

https://granitedevices.com/wiki/SimuCUBE_firmware_releases

Known issues:
Game crashes on startup or when getting in car. This will get worked on next.
Non-implemented effects, such as game-settable friction, inertia and damping. Now only the values from profile are used.
Maximum torque calculation is incorrect in the UI, and shows much too high values for some reason.

Please, do not put discussion into this thread.


#62

Just Done 2hr league Race in RF2 and flashed to new firmware just before
Overall felt allot better more tyre feel :slight_smile: was noticeable felt more connected in tight turns nearly on full lock.
Had no issues at all upgrade was very smooth.
Do remember to screen shot your profiles or write them down makes setting backup easy :sunglasses:
Very Happy with it :slight_smile:
Thank you Mika :grinning:


SimuCUBE firmware 0.7 vs. 0.8