SimuCUBE Open Source Firmware Development Update Thread 2

firmware

#81

Got sidetracked a bit, as showing encoder results in the UI turned out to be quite impossible with just polling the correct USB HID report at maximum possible rate.

I got a “slow” indicator now working, though. Hopefully it is enough, and we can implement the full directInput API reader later.


#82

First implementation of Directinput event reader I found, was not suitable :frowning:


#83

Anyone interested in a test build, with no backwards compatibility (i.e. if does not work, downgrade is possible but you will have to run the Motor Configuration Wizard again, and also profiles will be lost unless restored via ini file).

PM for details.


#84

Excuse me for asking a stupid question… what games uses DirectInput?

I can help with testing if I know what to test.


#85

Hello.
I did not understand what is asked. is it to test games for directinput tests? if so, i can test raceroom, dirt rally and rfactor 2

I don’t speak english


#86

I’m sorry to bother you but i have a strange problem with my osw.

It’s a Mige with a Biss and it’s on version 0.10.4 with IONI 10707.

The setup seem to run fine, the wheel moves to right and to left and normally stops at around 3 o’clock. When i turn on the SimuCUBE box the wheel moves as well.

But when i turn the wheel with my hands the position doesn’t update, it always says 0.01º and the wheel image in SimuCUBE doesn’t move either. Of course this reflects on Windows and on games, i get zero wheel position.

I don’t know what should i check next, i’ve lost the count of the number of times i’ve run the “configure motor, encoder and central point”.

Can anybody help or point to where the problem might reside.

Thanks.


#87

Try to connect to the drive by using Granity (remember to click the button on the Advanced tab first).

Then, on the Granity testing tab (once you have connected to the drive), you will see a position feedback indicator value.

The value should change when you turn the wheel. Report if it does or does not.

Also, show a screenshot of the content of the Machine -tab in Granity to verify that you have correct feedback device settings.


#88

Thanks.

This is the first time i run Granity.
I have Granity 1.14.1.
I get SimpleMotion USB (FT230X Basic UART) and it doesn’t connect.
I also have SimpleMotion serial port (COM6) and doesn’t connect either.
I installed the CDM20830 drivers.

Is there other version for this basic UART


#89

Did you remember to click the “Enable IONI USB Configuration” on the Advanced tab in SimuCUBE Configuration Tool first?


#90

Thanks again, i was reading the wiki and found that information there, now to check your precious tips.


#91

Position Feedbak is jumping between 0r and 4.76837e-07r, and Position Feedback (raw) between 0 and 1, it doesn’t matter if a turn the wheel or not, always jumping between those values.


#92

OK, so did it stop to work suddenly, or have you just gotten the unit? Is this a DIY build or a kit?

It is either a malfunctioning encoder or a wiring issue.


#93

I bought a kit and assembled it this saturday.

I tested the cable that goes from the feedback encoder, 7 pin cable with a multimeter in continuity mode and the cable is fine, so it leaves the encoder or internal wiring.

SimuCUBE side seems fine, don’t see any cold solder joints, so i have to open the Mige side to check wires (if it’s even possible) and then i can assume its the encoder, am i thinking right.

Thanks for the help.


#94

Yeah, you are right, it is possible to open the back cover of the Mige motor, but the wiring is usually quite protected and it is not possible to measure all pins there.

I would consider raising this issue to the supplier you got the kit from, due to warranty etc.

One additional thing: It has been an issue sometimes, that the DB15 encoder connector does not quite fit the socket in the SimuCUBE board because of various reason. Please double check that the cable sits fine in the connector.


#95

Just a quick update on my issue.

It’s solved, in between trying to receive information from the seller i went searching for datasheets, models and prices of 4.2mil Biss encoders for my Mige to replace the faulty one and found out a page in here on how to configure a Biss encoder and saw that it needed to be “Serial data encoder” and something clicked, i remembered seeing SinCos on the machine tab.

I got a .drc file from a osw similar to mine, loaded it and now it works. So it came misconfigured from the seller. And yes it’s 4a.m. in the morning, my brain has a problem, i know. Maybe my case will help someone in the future with similar symptoms.

Thanks Mika for all your help if it wasn’t from you i wouldn’t have found the solution to my problem, fortunately you exist as i was getting nothing from the seller.

Thanks again.


#96

Ah, yes indeed, I should have spotted that you specifically mentioned that you had BiSS encoder.


#97

Apparently this was a stupid question. :expressionless:


#98

Sorry I did not have time to answer that. All games use directinput; iRacing uses ConstantForce effect. But the DirectInput effect sliders are just for those games that use timed effects such as sine waves. I know that Raceroom uses some directinput effecsts for rumble strips, gear change effect etc, and that Euro/American Truck sims use Directinput effects for wheel centering (centering spring). Also Assetto Corsa can use DirectInput friction effect (I think) when car is stationary.

There is an indicator in the Configuration Tool as follows:
dash (-) means effect not used
○ means the effect has been created, but the game has not changed it’s parameters in last 30 seconds
● means that the effect has been created and the game has changed it’s parameters in last 30 seconds, i.e. it seems to be actively controlled by the game.


#99

Thank you Mika. You’re the best. =)


#100

@Mika any news from NL Print?