SimuCube Open Firmware keeps disconnecting


I’ve got a brand new SimuCube OSW with the small Mige motor. It is running OF 0.8.12,

On my Lenovo T470 laptop ecerything seems to wrok fine - I can use the config tool, make changes, and save them to the wheel - based on this I believe the wheel, drive, and firmware is working as it should. HOWEVER!!!

On my gaming PC, it sort of disconnects! For the config tool to see it, I have to open the config tool, then power on the wheel (E-sop released). It then ays witing on drive, and when my wheel beeps, is changes to operational. This is where the fun ends! On several occations, as soon as select a profile, the field is greyed out, and contact to the wheel is lost. I can’t see it move on the graphics, nor in Windows Gaming Devices (Running 10 Pro, latest build BTW).

On other occasions, I can load up a profile, but not make changes before it disconnects, and sometimes the profile name is corrupted. eg. having a profile named “test” might show up as “%657567(/&%¤”

I have tried the following:

Disabled power saving on USB Hubs in Windows

Old system:

Asrock z77 Extreme 4
32GB DDR3 1600
MSI 980 TI
Windows 10 Installe don Samsung 850 EVO

On this I have tried the onboard USB 2.0 ports, onboard USB 3.0 ports, addin USB 3.0 card <- All perform the same.

I have reinstalled the OS, and installed the latest drivers and firmware from Asrocks site.

As I have had some other USB issues on this computer AND the fact that everything seems to work on a couple of laptops, I went a bought a new system, which I have put together today

MSI z370 Gaming Carbon Pro AC
Intel i7-8700k
Kraken x62
Same Samsung SSD
Same MSI 980 TI
New case

Fresh install of Windows 10 Pro

I observe the exact same issues on this machine as on the other! Again with newest drivers / firmwares / Windows Updates. And still… It works completely fine on my laptop.

What am I missing? What can I do? ANY suggestions are welcome! I’m totally at a loss right now, not knowing wheather to go MMOS, or see if I can return the wheel (my former Fanatec CSR worked fine)


  • Thomas Marcussen

I am not the most knowledgeable around here but they will show up for sure so don’t give up.

Having said that. I suspect you have also plugged in your pedals and shifters via usb? If so try disconnecting them and boot with only simucube connected and see if the problem persists.
If so you could try using an other usb cable.

One more question do you have computer and simucube grounded properly? OSW is very sensytive when not grounded (mostly this causes gosting from shifters and buttons)

1 Like

Hi Eddy

Thanks for the reply.

The only other USB devices connected are my mouse and keyboard. I was not aware of the sensitivity to not being ground properly. I will find a replacement extension cord and make sure it has the ground plug as my current does not.

  • Thomas Marcussen

Thank you for pointing me in the right direction! Getting my grounding sorted, seems to have solved all issues. I can now start figuring out how to use the wheel and set it up.

Thanks again

  • Thomas Marcussen