SimuCube LED4 blinking

Hello Granite Team,

I have a prob with the SimuCube. I already contacted you per mail, because I didn’t know about the forum, sry abou that. I think the forum is a much better place to discuss such things.
So, to my prob!

since a few days I’m trying to set up my OSW with Lenze and SimuCube/IoniPro/MMos.
So far everything went well, until I started to play with MMos values. Since than the Led Nr.4 on the SimuCube is blinking permanently as soon as I switch it on (disconnecting the motor feedback device cables is not changing the status), and I’m not able to get any input into windows (WIN10-the cross hair in the game controller is not moving at all when I’m turning the wheel).
Even worse, I’m not able to save the device setting permanently.
On the wiki I did not found much information about this matter just that the led4 is connected to STM32F4 I/O pin PD15.
I tried so far everything (flashed ioni, uploaded MMos FW, checked every connection) but nothing worked.blinking
Esa answered to me per mail, that the LED4 is a clipping indicator, meaning that Mmos is clipping the output torque!!

Is there any way to reset the SimuCube board?

I’m very grateful for any help.
Best Regards


I don’t actually know what MMOS is doing with the leds. If there is documentation to point out some led does indicate clipping on the original OSW build using STM32F4 Discovery board and MMOS, then I don’t know about it. Our open-source firmware will have clipping indicator on that led.

For resetting the board, reflashing the MMOS using the STM Dfuse Demo should do enough to reset it.

If your MMOS software has connection to the board, there should a MMOS force feedback controller in the windows game controllers. Are you saying that you got the device there?

Hello Mika,

I searched the main MMos topic in the German forum for some information, but didn’t found anything (I think I’m the first person ever with that issue :weary:)

I do have connection between PC and MMos but, when I start to turn the motor shaft by hand the crosshair is not moving to left or right. I tried this on different PCs, same thing

I also tried today the STM32 ST-LINK Utility, but can’t get the connection between PC and the simucube. It seems it only works with the original STM disco boards.

Is there a way to hard core reset/erase the microcontroller state somehow (bridging 2 pins)?


Hello Dex,
Please post a screenshot of your MMoS setup, the display where you enter your encoder values etc.

It might be that you have indexing enabled and it is not working correctly?


Hi Beano,


As soon as I restart the app, all the settings in device setup window have gone back to 0.

Here are my ioni settings:

I think MMOS needs to have the encoder index actually located if use encoder index is enabled. There is a blinking led that should go out after the index has been found, and it might actually be the Led #4. Only after that the configs can be set via the MMOS tool - before that, it won’t do/save anything (although it seems to do).

Do you actually see the encoder working in Granity, and have you turned the wheel full 360 degrees before starting the MMOS utility?

i tried what Beano said. I deselected the option “use encoder index” and led4 stopped to blink.

Does this mean that my encoder cable is wired wrong, or I don’t need the indexing ?

Here is how i connected the encoder::

I took the pins 4,7,10,12,13,15,16 from the motor to bord pins 4,9,10,6,5,8,7

If index is enabled, and you restart the system, when you first open the MMoS settings and wheel has not been indexed, (not found), then those values will be empty.

So when you restart the system (Simucube), you will need to turn the wheel 180 degrees in both directions until that LED stops blinking. Only then, when you open the MMoS settings, will the values appear.

If you turn the wheel and it doesn’t index, you have a wiring mistake on your encoder plug, I would think. Remote chance the encoder is faulty, but start by checking all wiring on the 15-pin plug very thoroughly.


Beano, I tried your suggested setup sequence for indexing! Result still the same.
I tested all 7 wires with the continuity tester, so far it was ok.

Do I need some other pins (e.g.: Pin1)?

thread can be closed. I found the solution. I used the wrong schematic for the encoder cable (puhh… I was lucky enough, encoder is still ok).
This is the correct one:

OSW works now. Thanks guys.

great! enjoy the wheel