SIMUCUBE dropping out?

Hello everyone,

I’ve had my OSW from Sim Racing Bay working really well for quite some time now without really any problems. But for the past week or so, all the sudden the wheel kept dropping out, and I would have no FFB nor steering… And to get it running again, I’d switch it off & turn it back on. It would then keep working for quite some time. But now just last night, it kept doing it more often, and then it wouldn’t come back on at all. When I opened SIMUCUBE, it just said disconnected. Could not get the wheel to come back on at all. Checked all cables and tried unplugging & plugging back in… Couldn’t find any issue that would cause this. Has something burned out on my unit? I sure hope not… Any suggestions?

Typically some issues like this are caused by Windows deciding that USB devices are to be put to sleep mode.

However, turning off, and then turning on the Simucube system should always correct that issue.

Do you see any LEDs in the Simucube unit?
Does the wheel phase / beep etc at startup?
Is there bumbstops when it is turned on? (if you have configured them to be in use)
Do you have both USB cables connected? If so, there should be the FTDI Serial Port device becoming available / disappearing in Device Manager. Also, you could use USBDeView software to see if the device is indeed dead, see

Any info about these would help to pinpoint the issue.

Silly me… I had checked all of the cables but one… The power lead where it goes into the box directly under the switch! Apparently it had started to work its way out from me bumping it when turning on, and wasn’t getting full contact for a while (causing intermittent problems), and then had worked its way too far out to come back on. Whew! All good now that I pushed it all the way in. But I sure feel like a big dummy! :crazy_face:

1 Like