Simucube did not boot in Firmware Upgrade Mode


just installed the Simucube 2 pro and get this error message from True Drive 1.0.8

I have checked the following steps in the error message but nothing helps, any ideas on what I should do?

Can I manually set it in Firmware upgrade mode so true drive can upgrade it?


Hi Alexander . maybe you have the E STOP pressed down …must be UP. regards Denis

Hi thanks for answering but the e-stop is up already :frowning:

I solved this, tried every usb port I have and on the last one it finally worked while also turning SC2 on and off multiple times :slight_smile:


Good to hear you got it working ok.have fun

I’m having this same issue, I have tried every single USB port on my Desktop and still cannot get the SC2 Pro to boot onto firmware upgrade mode.

Is the e-stop up? Can you try to toggle it?

Hey Mika,

So I worked through the issue, the E Stop was up, and I had every process turned off and USB unplugged. I could still not remedy the issue on my primary system. I ended up having to use a separate Surface Pro Notebook to flash the firmware.

My guess is that the MSI Z490 motherboard has some sort of driver for the LEDs that is interfering with how the SC2 interfaces. As even with removing the MSI bloatware I could not completely wipe LEDKEEPER.EXE without editing the registry.