SimuCube - device is not visible in device manager

simucube

#1

Hi,
I have a problem with new OSW kit ordered from simracingbay. I’ve connected everything but Simucube isn’t visible on my PC at all, no new devices, devices list isn’t even refreshing. No new COM ports, no device plug notification sound/popup. It looks just like USB ports are dead.
Besides communication issue with PC it looks like servo is working fine after turning power on, wheel rotates slightly few times and a second after that beeping sound is played, there is one green led on Simucube board, and orange one on Ioni servo drive.
So far I’ve tried:

  • updating my bios
  • connecting it to 3.0 usb ports
  • connecting it to 2.0 usb ports
  • connecting it to external pci-e 2.0 usb ports
  • checked on other pc
  • updated bios on other pc and checked again ;/
  • forcing simucube into dfu mode by changing dip switch position on pcb
  • downloading granite software and simucube software, both can’t detect wheel
  • using different usb cables

Honestly I’m out of ideas and would be really glad if someone could help me ; /

My kit was preconfigured and tested so it should have updated firmware and bootloader.

PS: I have contacted Tomo by email and we are working on resolving this issue together but I wanted to also look for help here in case that maybe someone had similiar issue and was able to resolve it on his own.


#2

have you tried updating the granite devices fimware or simucube. I had that issue but as soon as i updated the granite devices firmware it worked or re start granite devices. just go into simucube/advanced/enable ioni usb config/ once that is enabled load up granite devices software and go to the connect tab then connect click ok then down the bottom left side of screen you will see restart granite devies and install firmware, try those two. it helped. You may already know this im just trying to help


#3

How can I update firmware if SimuCube is not visible to my PC? Is it possible to connect it using different method other than USB cables?


#4

Yeah, sounds like there is some type of USB issue that, for sure, has nothing to do with IONI servo drive firmware or software.

I would put the Simucube board into DFU mode by using the dip switch method, to see if there is indeed an issue with the Simucube board and its firmware.


#5

Or is it the USB cable itself that’s a problem?


#6

My first thoughts were are both USB ports on the Simucube connected to PC USB ports?


#7

@Mika I have put it in DFU mode, and I have tried connecting it using USB port closer to RJ45 ports but it still has not been visible.
@phillip.vanrensburg It’s not USB cable sadly, I have tried connecting it using other cables and device still has not been visible.


#8

@16sth honesty i think I’ve tried every possible combination by now : :thinking:

Sorry for double post but new users can’t mention more than 2 people in single post.


#9

it sounds like doa to me.