Simucube bumpstop stopped working

My hardware configuration:
I’m using the 30 Nm motor from simracingbay.

SimuCUBE hardware version: Revision 2(r005)
SimuCUBE firmware version: 0.11.0
Configuration tool version: 0.11.0
IONI drive firmware version 10707

Problems arise when:
All of a sudden bumpstopped working one day, can’t remember anything specific I did.

How it behaves:
The wheel just keeps on rotating even when I go past the set steering range.

How I would expect it to behave:
From what I remember if I enable bumpstop it should stop me from going further then the set steering range.

Try to change the bumpstop range at least once back to default value (10 degrees).

No difference. I tried both with -10 and 10 degrees. In the hardware settings I got
bumpstop effect enabled = true
bumpstop maxium strength 20% I’ve also tried 100% here
bumpstop effect ramp angle 1 degree
bumpstop damping effect 0% I’ve also tried 100% here

There is a LED on the Simucube board that should activate once you turn past the angle of the bumbstop. Does it light up?

Also, later firmware versions such as 0.11.2 (and 0.11.0 might have, can’t remember anymore) a text description of the different firmware status bits on the Advanced tab. What status bits are active?

I could not find anything about the firmware status bits.
I did tho see a LED light up whenever I went over the bumpstop, hopefully this is good?

OK, then I would suggest to update the firmware to 0.11.2, as we are still somewhat supporting that version and know its quirks better.

Try increasing your bumpstop strength, my friend had to do this otherwise the game’s ffb overuled it(?)

yeah, that firmware also has the issue that if game FFB is stronger in opposite direction, it overrules the bumpstop.

Updated SimuCUBE firmware version to 0.11.2 and no changes.
I tried increasing the bumpstop strength to 100% and no difference.
I don’t even have a game running so I don’t believe FFB from somewhere else is interfeering.
I tried open a game and the FFB works as ussual once I turn past the steering range and the FFB just turns off from the game.

try to change each of the bumpstop settings, including the damping, at least once to non-zero value.

Do I have to be in a game for the bumpstop to work or would just being at the desktop work?

Being at desktop would also work.

Not sure really what fixed it but I just changed every parameter and now it works! Thanks! It was probably Bumpstop effect ramp range that fixed it! I just changed it to 0 and back.


And you got a newer firmware :slight_smile: Ha det bäst!

Most likely it was an underlying issue in 0.11.0 and that the workaround for it only worked in 0.11.2. More permanent fix should be in 0.50.x versions, which force some of the parameters to values that are good to use.