Simucube board with Ioni HC driver, 24vdc?

Does anyone know if the granite simucube board with ioni drive will be able to run a small mige motor with an input of 24vdc? I know this is not ideal, but its temporary. I totally understand if there is not enough voltage to provide the full torque of the small mige motor.


It should work, but to make 100% sure, post your motor/specs and /or model here…

But if it is a MiGe servo for example, most of them will run on 24V, just not optimally, like you have noted, as they might be voltage-limited and not allow full-torque at 24V. But this is nothing new or weird, all the AKM servos used in the Bodnar SS2, for example, are somewhat limited even at 48V.

Same goes for the large Mige, or the Lenze I have used for many years. …

THanks, its just the normal small midge m130 motor with the biss C encoder. Also does anyone know if the stock cable from mige will work directly into a simucube board?

All good then. You will not have any issues.

Just ask Lisa to make the cable compatible with Simucube, but I think it already is anyway with the BiSS-c encoders they supply :wink:

yes, i think she did that. Of course now I have new issues. Granity is not detecting my ioni drive!.. I did at one point. Which direction do the dipswitches need to be in for configuration? I cant seem to figure it out. I am so confused with the granity wiki and info, so many confusing parts called simucube. I have the PCB with the ioni drive. It wont find any drives anymore. I have tried two computers now. granity pcb shows logic ok, and ioni shows 3 flashes then a long flash. estop button is depressed (safe torque is off).
@phillip.vanrensburg thanks for your help so far.

Does your pc detect the Simucube at least?

Please post screenshots of your true-drive window settings on all tabs, I will help you from there. I need to go mow the lawn now, but will be back to guide you in ~2.5 hours.

One last thing, you need yo have nothing USB cables to be connected to the Simucube for Granity and HID USB to work, there is a software enable in the true-drive though to switch between accessing Granity /Ioni config and using HiD USB gaming interface…

So with dfu switched on, and the other dipswitch set to on, it detects a usb port when I power up the board.

It wont connect, so not sure sending you the screenshots will help. The ioni is complaining that a servo drive mode is not selected (based on the flashing sequence). But I cant even connect to the ioni board at this point.

It never shows up in the “list of found & powered drives”…

can you help me for 10 minutes before starting your lawn? i wont have time later.

Let’s see later today if I find time to remote to your pc to help you. It seems that might be the easiest way to go. Do you have TeamViewer installed on your pc?

Sorry, it won’t be 10min and I can’t do it now, need to get outside before it gets to 35 deg c here :frowning:

yes… illl set it up now…

354 615 499

pw 1k36zv

ok thanks… i will wipe the teamviewer setup… if there is direct chat on this forum maybe that would be better

One other note, the USB port in my device manager doesnt say simplemotion anymore, it now says “USB Serial Port (Com6)”… i may have changed the ioni address, by loading a config file from someone online. The file I used was "Simucube_Mige_130ST_M10010_5amp.drc which I think had the wrong encoder selected. After I tried that file, things stopped working.

@phillip.vanrensburg do you have time now?

@phillip.vanrensburg I got it to work. Thanks mate. The motor had a crimped connection on the 5v to the shell of the db15. I was also using granity instead of simucube configuration tool. Now my motor is working as it should.

This is great news, now you’re a specialist on it :slight_smile Well done, Mate!

Yes, True Drive is mainly for configuring the base Simucube HID and them most common settings used in filtering.

Granity Tool is mostly used by power-tuners to access some hidden configuration parameters for the servo-drive itself. On Simucube 2, these aren’t even accessible any longer. But Granity is still required on Simucube 1 in case we have problematic cases, which doesn’t happen very often, but if it does, sometimes the only way I could recover was via access to Granity.

Anyway, you’re sorted, now enjoy your dd wheel :slight_smile: