Simucube 2 Ultimate dead?

I have my Ultimate about 2 weeks now and it worked fine.
Today i tried to operate it and it is dead… ;(
the power supply is on (both read and green light) but the motor light is off… ;(

Any ideas ?! Is there any Fuse that i can check ?!

Shall i send it to the dealer i bought it from, or to simucube directly ?!


Simucube 2 products require USB power via the USB cable. Can you first try with another cable and another USB port?

Thank you Mika for the very quick reply.

It is not the usb though i swapped the port and the cable with an other one.
It is not the fuse on the power supply as well as i found it and i checked it…

It is not the estop button either…

Is there any fuse inside the motor or sth ?!

I spoke with my dealer and i will send it back tomorrow.

Hello Nick,
There is no user-changeable fuse inside the unit.

Just to double-check, before you ship it, can you switch off the main PSU, wait 1 minute, then remove cable from PSU to Servo both at PSU and Servo ends, and replug. Also, remove the E-Stop/Power button cable both ends, and reconnect.

Switch on the PSU and retest.