Simucube 2 True Drive driver error

Whilist I was using the wheel I never closed the software, just kept alt tabbing and saving to simucube if I made any changes. It just froze on me one time, the ffb and wheel tracking got bugged, then I was like let me kill the process and restart the software, but it didn’t like my approach.

Hmm :thinking:, I have yet to have anything like that happen in my use.

Hi Mika!

I’ve copied some data about the crashes from windows logs and through the control panel’s security and maintenance, and made a few pics about the software with the wheelbase being turned off and then on and then being frozen, and 2 videos about the above mentioned games.

Here they are:

I hope it helps in some way.

Those windows logs are not really helpful.

Please make a shortcut to True Drive.exe like this:


and then paste the contents of what goes into the log.txt file that will be generated.

Also, does the X-axis move in Windows control panel or in DiView softwares?

Here you go, and the X-axis doesn’t move in either programs.

19:17:41.656: Opened style file
19:17:41.880: Warning: QMetaObject::connectSlotsByName: No matching signal for on_wirelessbutton_clicked()
19:17:41.891: “E:/Simucube_2_true_drive_v1.0.13/Simucube_2_true_drive_v1.0.13/simucubeprofiles.ini”
19:17:41.893: “E:/Simucube_2_true_drive_v1.0.13/Simucube_2_true_drive_v1.0.13/profiles_autobackup.ini”
19:17:41.895: “E:/Simucube_2_true_drive_v1.0.13/Simucube_2_true_drive_v1.0.13/profiles_autobackup.ini”
19:17:41.912: loadIncludedFirmwareVersion: included 1.0.13
19:17:42.883: EULA previously accepted.
19:17:42.890: Disconnected state
19:17:42.895: unable to open device, pid: 3423
19:17:57.901: Connected to SC2 Pro
19:17:57.904: reconnected

19:20:16.524: Opened style file
19:20:16.758: Warning: QMetaObject::connectSlotsByName: No matching signal for on_wirelessbutton_clicked()
19:20:16.769: “E:/Simucube_2_true_drive_v1.0.13/Simucube_2_true_drive_v1.0.13/simucubeprofiles.ini”
19:20:16.771: “E:/Simucube_2_true_drive_v1.0.13/Simucube_2_true_drive_v1.0.13/profiles_autobackup.ini”
19:20:16.774: “E:/Simucube_2_true_drive_v1.0.13/Simucube_2_true_drive_v1.0.13/profiles_autobackup.ini”
19:20:16.791: loadIncludedFirmwareVersion: included 1.0.13
19:20:17.768: EULA previously accepted.
19:20:17.774: Disconnected state
19:20:17.780: unable to open device, pid: 3423
19:20:32.787: Connected to SC2 Pro
19:20:32.790: reconnected
19:20:51.400: disconnection2askstatus
19:20:51.405: disconnection due to status update read failure.
19:20:52.798: Disconnected state
19:20:52.801: pid 3424
19:20:53.788: Disconnected state
19:20:53.791: pid 3424
19:20:54.796: Disconnected state
19:20:54.800: pid 3424
19:20:55.785: Disconnected state
19:20:55.789: pid 3424
19:20:56.799: Disconnected state
19:20:56.803: pid 3424
19:20:57.786: Disconnected state
19:20:57.790: pid 3424
19:20:58.798: Disconnected state
19:20:58.801: pid 3424
19:20:59.800: Disconnected state
19:20:59.803: pid 3424
19:21:00.791: Disconnected state
19:21:00.794: pid 3424
19:21:01.791: Disconnected state
19:21:01.795: pid 3424
19:21:02.801: Disconnected state
19:21:02.804: pid 3424
19:21:03.787: Disconnected state
19:21:03.790: pid 3424
19:21:04.796: Disconnected state
19:21:04.799: pid 3424
19:21:05.792: Disconnected state
19:21:05.795: pid 3424
19:21:06.786: Disconnected state
19:21:06.790: pid 3424
19:21:07.787: Disconnected state
19:21:07.790: pid 3424
19:21:08.798: Disconnected state
19:21:08.802: pid 3424
19:21:09.801: Disconnected state
19:21:09.804: pid 3424
19:21:10.786: Disconnected state
19:21:10.790: pid 3424
19:21:11.800: Disconnected state
19:21:11.803: pid 3424
19:21:12.790: Disconnected state
19:21:12.793: pid 3424
19:21:13.801: Disconnected state
19:21:13.804: pid 3424
19:21:14.809: Disconnected state
19:21:14.813: pid 3424
19:21:15.803: Disconnected state
19:21:15.807: pid 3424
19:21:16.808: Disconnected state
19:21:16.812: pid 3424
19:21:17.815: Disconnected state
19:21:17.819: pid 3424
19:21:18.804: Disconnected state
19:21:18.807: pid 3424
19:21:19.807: Disconnected state
19:21:19.811: pid 3424
19:21:20.808: Disconnected state
19:21:20.812: pid 3424
19:21:21.804: Disconnected state
19:21:21.808: pid 3424
19:21:22.814: Disconnected state
19:21:22.818: pid 3424
19:21:23.801: Disconnected state
19:21:23.805: pid 3424
19:21:24.815: Disconnected state
19:21:24.819: pid 3424
19:21:24.824: reconnected
19:21:25.329: got a response
19:21:25.536: loadIncludedFirmwareVersion: included 1.0.13
19:21:25.538: shouldShowFirmwareUpdatePrompt: device reported 1.0.13
19:21:25.541: first connection done
19:21:25.544: no need to update
19:21:25.546: checked fw update need
19:21:39.832: read timeout failure 1 (500 ms elapsed, no response at all) at “getProfileData1”
19:21:39.835: disconnection due to profiledata read failure.
19:21:40.842: Disconnected state
19:21:40.845: pid 3424
19:21:55.852: reconnected
19:21:56.858: read timeout failure 1 (500 ms elapsed, no response at all) at “askSimucubeStatusNew()”
19:21:56.860: askSimuCubeStatusNew disconnection
19:21:56.863: disconnection due to status update read failure.
19:21:57.833: Disconnected state
19:21:57.836: pid 3424
19:22:12.843: reconnected

Looks like some sort of USB interference issue. Which motherboard and which port is your Simucube connected to?


It’s in one of the motherboards 2.0 usb ports. I did try the front ports and a 3.0 and 3.1 port on the motherboard but it didn’t work there as well. The 2nd usb view picture is after a few seconds of the wheelbase beeping, and pressing refresh on the program.

We have seen a few USB cable issues. Can you try with another USB cable? Also, it might be worth to try with another computer/laptop if possible.

I have tried a working usb cable and my laptop. It didn’t work, log shows the same data.


Do you still have an issue? Unfortunately we’ve been very busy with other projects during the recent week or so. If the situation has not progressed, I might be able to help you over the weekend. There is a need to implement a service feature that also refreshes the profile and hardware settings at every boot anyway in case there is a software issue.

Actually, I was able to make such special firmware - lets continue in private.

Hey Mika,

Yeah I still have the issue, that would be great and I am looking forward to it.

We were able to solve the issue. While the exact cause is still unknown, we do have some ideas. There is a special firmware available directly from us now that can be used to unbrick a Simucube 2 device.


Great work Mika. Well done!

Brilliant that @Laci821 could get up and running again without having to ship the servo back to base :+1:

1 Like

Indeed, tested heavily on Assetto Corsa, Dirt Rally 2.0 and RaceRoom. The wheelbase works wonderfully :smile: , all thanks to Mika!


Hi, i have the same issue.

I Installed vJoy and IRFFB to improve the ffb and the wheel stopped show in True Drive. It shows in windows as connected device as normally. And the wheel base has the blue light on the back. I paste the log when executed TD:

17:27:11.078: Opened style file
17:27:11.393: Warning: QMetaObject::connectSlotsByName: No matching signal for on_wirelessbutton_clicked()
17:27:11.409: “C:/Users/vikto/OneDrive/Escritorio/Simucube_2_true_drive_v1.0.13/simucubeprofiles.ini”
17:27:11.412: “C:/Users/vikto/OneDrive/Escritorio/Simucube_2_true_drive_v1.0.13/profiles_autobackup.ini”
17:27:11.415: “C:/Users/vikto/OneDrive/Escritorio/Simucube_2_true_drive_v1.0.13/profiles_autobackup.ini”
17:27:11.437: loadIncludedFirmwareVersion: included 1.0.13
17:27:12.405: EULA previously accepted.
17:27:12.413: Disconnected state
17:27:12.419: unable to open device, pid: 3423
17:27:12.425: unable to open device, pid: 3424
17:27:12.430: unable to open device, pid: 3425
17:27:12.434: Could not connect to SC2
17:27:13.406: Disconnected state
17:27:13.413: unable to open device, pid: 3423
17:27:13.418: unable to open device, pid: 3424
17:27:13.423: unable to open device, pid: 3425
17:27:13.426: Could not connect to SC2
17:27:14.389: Disconnected state
17:27:14.396: unable to open device, pid: 3423
17:27:14.401: unable to open device, pid: 3424
17:27:14.406: unable to open device, pid: 3425
17:27:14.409: Could not connect to SC2
17:27:15.409: Disconnected state
17:27:15.417: unable to open device, pid: 3423
17:27:15.423: unable to open device, pid: 3424
17:27:15.429: unable to open device, pid: 3425
17:27:15.432: Could not connect to SC2

Tried to reconnect, disconnect, unistalled vjoy, restart pc etc etc but anything happens :frowning: some solution? thanks

it appears not to be the same issue, as it does not find any of the device ID’s. Maybe vjoy is interfering somehow.

Maybe. I uninstalled and eliminated all the extra files from vjoy but nothing happens. Dont really know what to do

the wheel works on other pc , laptop ?

Hi, sorry for the late response.

Finally I reinstalled Windows and it worked good. It must be some .reg file or something that was modified. It´s not fun to reinstall everything but it´s good to know that the wheel wasn´t the problem :slight_smile: